Fairled to Copy: chtimes error (but no error?)

What is the problem you are having with rclone?

Occasionally (ranges from about 10% of files to 50% of files) get the following error:
ERROR : Filepath/Filename: Failed to copy: chtimes \?\X:\Filepath\Filename: The system cannot find the file specified.

Oddly when I check the file sizes and try running anything I've uploaded that has this error, it still runs fine. But seeing the constant errors is a little concerning...

It looks like this thread had a similar issue, but I couldn't figure out the solution was: Windows 10 - Rclone copies files over to mounted storage yet "failed to copy: chtimes: " error is displayed

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 64 biy

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount gCrypt: X: --attr-timeout 1000h --dir-cache-time 1000h --poll-interval 0 --rc --vfs-cache-mode writes --vfs-read-chunk-size 32M -v --config "C:\Users\abc\.config\rclone\rclone.conf"

followed by:

rclone copy --verbose --ignore-existing “D:\ToTransfer” “X:/Transferred/” --bwlimit 8704k --transfers=2

A log from the command with the -vv flag

2020/09/18 07:05:50 ERROR : Folder1/Season1/[1] File1 - Ep1 [1] [1].mkv: Failed to copy: chtimes \\?\X:\Transferred\Folder1\Season1\[1] File1 - Ep1 [1] [1].mkv: The system cannot find the file specified.

I believe this was fixed for v1.53. Please try with that release and let us know if you are still facing the issue.

Thank you! This may be an obvious answer, but what's the process to update rclone (ideally without redoing the current mounts)?

Depending on your platform, the steps are available at: https://rclone.org/install/

rclone is a single executable file, a portable app.
on windows, there is no install - just download the .exe and run it.

Thank you! So it did technically fix it, but now I'm getting a whole different issue. After it transfers a few files, the speed drops down to 0 Mb/s for some period of time (haven't found any consistencies yet) and then comes back to normal speeds.

For example, I was transferring about 200 files with transferring 2 files at a time. After the first two finished, the speed dropped to 0 for about 20 minutes and then came back to normal speeds. After the next file finished transferring, the speed dropped to 0 for about 4 minutes and then came back to normal speeds.

Any suggestions?

before rclone uploads a file, it calculates the checksum of the local file(s).

so if you are uploading just two files at a time and those two files are large, rclone will take some time before upload starts again.

you are using rclone twice for uploads.

  1. for the mount
  2. rclone copy local to the mount.

it would be more efficient to not use the mount at all.
rclone copy D:\ToTransfer gCrypt:Transferred

Ah I will try that! Right now I'm uploading 1 file that is around 50GB, but the rest of the files are around 2GB. So usually (not all of the time) after one of the 2GB files finish, that's when it slows to a halt. Does that sound relatively normal?

One thing I forgot to mention was I do always need have the drive mounted for other uses, so that will always be running in the background.

sure, i always have a mount running,
but whenever i can use rclone copy, there are a bunch of reasons to do so.

You're absolutely right! No issues so far! I'm going to wait until this full import finishes and then I'll mark this as solved.

as i understand it, when using a mount, and let's say windows explorer,
only one file is uploaded/downloaded/processed at a time.

So everything uploaded extremely smoothly. I checked by running:

rclone check --one-way --size-only “D:\ToTransfer” gCrypt:Transferred

And it said:

2020/09/23 13:14:59 NOTICE: Encrypted drive 'gCrypt:Transferred': 0 differences found
2020/09/23 13:14:59 NOTICE: Encrypted drive 'gCrypt:Transferred': 20 matching files

But when I checked the mounted drive through Windows Explorer, I don't see the files and that folder is empty? Any thoughts?

as a test, do a dir x: /s for

  • a command prompt with admin rights.
  • a command prompt without admin rights.

When I first ran it, it started listing all the files I had on X: (which would have taken quite a while). So I did stop it and ran:

dir x:Transferred /s

Interestingly, the output I got was:

 Directory of X:\Transferred

04/30/2020  02:15 PM    <DIR>          .
09/22/2020  05:29 AM    <DIR>          ..
               0 File(s)              0 bytes

     Total Files Listed:
               0 File(s)              0 bytes
               2 Dir(s)  XXX bytes free

So here it looks like there aren't any files...

so the mount is working, as the dir /s gave output

and without using debug logs, can cannot figure out what happened?

Okay! Quick question, to get the debug log, I would run the following, right?

--log-level INFO

And if yes, what I should I run it along side? The rclone copy syntax?



So I'm not exactly sure what changed, but once I restarted my computer all of the files now appear in explorer...

I just tried doing two other uploads afterwards. After the first one, the files appeared in windows explorer just fine. I uploaded additional files afterwards and they did not appear (include files from the first upload). After restarting they all appeared. Any suggestions?

Would you like me to still post a debug log since it does actually transfer?