Error verifying OneDrive access credentials

What is the problem you are having with rclone?

I created OneDrive access credentials in rclone and entered them in TrueNAS 12.0-U3 Cloud Credentials. When I click Verify Credentials I get the error message:
failed to get root: Get "": dial tcp connect: network is unreachable

I then tried Logon to Provider and got this error:
HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /common/oauth2/v2.0/token (Caused by NewConnectionError(': Failed to establish a new connection: [Errno 51] Network is unreachable'))

I don't know if this issue is with rclone, TrueNAS or Microsoft.

What is your rclone version (output from rclone version)

I have rclone v1.55.1-osx-amd64

Which OS you are using and how many bits (eg Windows 7, 64 bit)

I ran rclone to create the credentials in macOS 10.15.7 which is 64 bit. My TrueNAS is running 12.0-U3.

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

I was using the TrueNAS Cloud Credential functions Verify Credential and Login to Provider. But I don't know if these use rclone code.

Paste command here

See above

The rclone config contents with secrets removed.

Screen Shot 2021-04-29 at 1.18.20 pm.png

A log from the command with the -vv flag

Paste  log here

I have more detailed error information but I need to know if the error is from rclone, TrueNAS or Microsoft.

does not look like a rclone issue.
either a network issue, truenas or some glitch with micro$soft servers.

until you figure that out,
you can try a headless setup or copy a config file from one computer to the truenas

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.