Confused newbie

What is the problem you are having with rclone?

as a newbie im struggling to mount mega as my drive

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

ubuntu 20.04

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

This is what i am stuck with. my folder structor is this mega/films mega/tv i am trying to mount the drive so all of mega is readable.

not sure what command i need to enter.

Paste command here

The rclone config contents with secrets removed.

Paste config here

-1 2021-03-05 07:59:48 -1 Films
-1 2021-03-12 12:33:15 -1 Fitness
-1 2021-03-05 08:00:14 -1 Formula 1
-1 2021-03-05 08:07:14 -1 TV
-1 2021-03-11 19:01:01 -1 Torrents
-1 2021-03-05 08:00:14 -1 UFC
-1 2021-03-05 08:00:14 -1 Wrestling
-1 2021-01-28 21:38:26 -1 apks
-1 2021-01-10 17:26:39 -1 files

A log from the command with the -vv flag

Paste  log here

what is the name of the remote?
rclone listremotes

let's called it remote

to mount that
rclone mount remote: /path/to/local/folder

1 Like

maybe im being dumb the bit thats confusing me is the path to local mount? im not sure
what the path is? and what flags i need to add to as well? sorry this bit always confuses me

create a new empty folder; perhaps under you home dir
mkdir /home/user01/mount
rclone mount remote: /home/user01/mount --allow-other

literally followed this and got this

2021/03/17 18:54:45 Fatal error: unknown flag: --allow

Think i did it i did allow-other it seems to be stuck or taking its time to do it so fingers crossed

stuck here

root@localhost:~# rclone mount mega: /home/hhh/mount --allow-other

(i created the hhh folder and mega: is because i named the mega mega on the config

sorry one more thing this has come up now

2021/03/17 18:59:00 NOTICE: mega root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream

try rclone mount mega: /home/hhh/mount --allow-other

to enable --allow-other, need to edit /etc/fuse.conf and uncomment user_allow_other

# Allow non-root users to specify the allow_other or allow_root mount options.

would i be better off deleting and re starting? do i need the vfs cache as well as im using this for streaming to plex and jellyfin?

delete what?

this command works for me,
rclone mount wasabi01: /home/user01/mount

you said the allow other command need to edit the conf file? sorry for all the questions

try rclone mount mega: /home/hhh/mount

done that and getting this?
2021/03/17 19:17:15 NOTICE: mega root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream

does this mean its done anyway?

add --vfs-cache-mode full

so rclone mount mega: /home/hhh/mount --vfs-cache-mode-full?

19:28:16 Fatal error: unknown flag: --vfs-cache-mode-full
when i do the command above?

no, add exactly what i gave you.

sorry my brain isnt working tonight.

ive done the rclone mount mega: /home/hhh/mount

i get this mega root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream

sorry im lost now. This has always got me stumped. when i used to use mega it was easy to follow step by step.

really lost what command i need to use now

rclone mount mega: /home/hhh/mount --vfs-cache-mode full

just doing nothing with this command just been on here for 10 minutes now

that looks good. rclone mount does not return to the command line, keeps running.

have you tried to look at the mount folder /home/hhh/mount

its doing nothing. Its literally just sat when i hit enter on the rclone mount mega: /home/hhh/mount --vfs-cache-mode full

nothing happens it just sits there