Cant use two remotes together

What is the problem you are having with rclone?

am trying to use two remotes backend and no matter what i do (either via rclone union+mergerfs, rclone combine+mergerfs mount and regular rclone remote+mergerfs mount) i have this issue where am unable to fast-forward within plex ios client, plex webui, etc (i have gotten it to work for example in the plex webui but then it doesn't work on the ios app but then it stops working anywhere all together). i have tried every possible combination i can think off for the rclone union such as all/all/ff and many more combination.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.3

  • os/version: debian 12.4 (64 bit)
  • os/kernel: 6.1.0-17-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)


Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = dropbox
token = XXX

type = crypt
remote = dropbox:
filename_encoding = base32768
password = XXX
password2 = XXX

type = yandex
token = XXX

type = crypt
remote = yandex:
filename_encoding = base32768
password = XXX
password2 = XXX

type = union
action_policy = all
create_policy = all
search_policy = ff
upstreams = "yandex_encrypted:" "dropbox_encrypted::nc"

type = combine
upstreams = upstreams = "yandex_encrypted=yandex_encrypted:" "dropbox_encrypted=dropbox_encrypted:"

A log from the command that you were trying to run with the -vv flag


here is a screenshot of the issue when trying to download from plex using idm:

and here is some info/ research i was using as reference:

And how do you mount it? What is your rclone mount command?

sorry about that. here are my mount setting. please ignore the commented out arguments.

ExecStart=/usr/bin/rclone mount mounts_merged_union: /media/mergerfs/mounts_merged_union \
	#--config=/home/aniel/.config/rclone/rclone.conf \
	--log-file=/media/logs/mounts_merged_union.log \
	#--vfs-write-back 10m \
	#--min-age 1s \
	--ignore-existing \
	#--vfs-fast-fingerprint \
	#--rc-no-auth \
	#--rc-addr \
	#--rc \
	--allow-other \
	#--allow-non-empty \
	--log-level=NOTICE \
	--dir-cache-time 9999h \
	#--vfs-cache-poll-interval 5m \
	--vfs-cache-max-age 9999h \
	#--vfs-read-chunk-size 1M \
	#--vfs-read-chunk-size-limit off \
	#--cache-dir=/media/mergerfs/local_hdd/rclone_cache \
	--vfs-cache-mode full \
	--vfs-cache-max-size 100G \
	#--buffer-size 0M \
	#--vfs-read-ahead 32M \
	#--tpslimit 10 \
	#--tpslimit-burst 0 \
	#--multi-thread-streams 0 \
	#--cutoff-mode cautious \
	#--network-mode \
	#--read-only \
	#--order-by size,mixed,75 \
	#--max-backlog 10000 \
	#--transfers 1 \
	#--checkers 0 \
	#--contimeout 30m \
	#--timeout 30m \
	#--retries-sleep 60s \
	--umask 002
ExecStop=/usr/bin/fusermount -uz /media/mergerfs/mounts_merged_union
#ExecStartPost=/usr/bin/rclone rc vfs/refresh recursive=true --url _async=true


i have tried couple of combinations of all this arguments but none seems to make a difference, here are some examples:

bare minimal (for my understanding):
--vfs-cache-mode full
--vfs-cache-max-size 100G
--umask 002

optimal one (at least for dropbox):
--dir-cache-time 9999h
--vfs-cache-poll-interval 5m
--vfs-cache-max-age 9999h
--vfs-read-chunk-size-limit off
--vfs-cache-mode full
--vfs-cache-max-size 100G
--tpslimit 10
--tpslimit-burst 0
--order-by size,mixed,75
--max-backlog 10000
--umask 002


any other arguments are there because I might have tried either some recently or on the past but am too lazy to delete them in case i need them (don't ask me why)

I also have not tried but am assuming if were to separate and mount the two remotes separated and then use them individually within plex then things would work but I was hoping to combine them (media) folder

for the regular rclone remotes+mergerfs configuration this is the mergerfs i have used to combine the two remotes (media) folder

Description=mergerfs merged mounts

ExecStart=/usr/bin/mergerfs /media/mergerfs/mounts/dropbox_encrypted:/media/mergerfs/mounts/yandex_encrypted /media/mergerfs/merged -o rw,use_ino,allow_other,category.action=all,category.create=ff,async_read=false,func.getattr=newest,statfs_ignore=nc,dropcacheonclose=true


I do not see any obvious misconfiguration here. IMO rclone part should work.

But I am not sure what do you use mergerfs for. Maybe I am missing something but it looks like out of place over complication.

Can you try without it? Simply pointing Plex to your rclone union mountpoint?

yes i did tried it as well same issue still happening

Tried what? Single remote without mergerfs?

I start to believe that problem is not with rclone and its configuration but with your other software you are using.

for my understanding there is no way to mount a rclone remote to a local folder without mergerfs, right? am i missing something?

rclone mount remote: /path/to/local/folder

ohh that is right. let me try that quick and report back.

I tried with "rclone mount mounts: /media/mergerfs/mounts --vfs-cache-mode full --vfs-cache-max-size 100G" and same results

Yes it is probably nothing to do with rclone. You can not resume video from rclone mount with --vfs-cache-mode full - it is something myself and many other users use daily without any issues.

For a test you can try to copy some videos to local folder and try to play from there. So you will remove rclone completely - most likely you will have the same issue.

Maybe other plex/idm users ca give you some advice.

u are right. after doing some ts with emby it seems this is not an rclone and/or mergerfs issue but rather a plex and/or plex/vpn issue, thank you for your help.

1 Like

the issue ended being me trying to use "--dir-cache-time 1s" instead of "--dir-cache-time 9999h" and also this flag i think were causing issues

--order-by size,mixed,75
--max-backlog 10000

Thx for sharing.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.