Can't run some binary files(.exe) on mounted disk

What is the problem you are having with rclone?

Some binary files (like 7z.exe) can't open via double clink on Windows system, always get "Windows can not access N:\7z.x64.exe", error code 0x900704b3
(However, some binary files(.exe) can be open through double click...)
Already read all related posts, I'm not to using the admin acount to run rclone, and already used --file-perms option while running.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.0
- os/version: Microsoft Windows 10 Pro for Workstations 21H2 (64 bit)
- os/kernel: 10.0.19044.3086 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.20.5
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Model name: DS415play
Current DSM version: DSM 7.2.0
This is the latest version available based on your current DSM configurations.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount NAS: N: --vfs-cache-mode=writes --no-check-certificate --file-perms=0777 --cache-dir=d:\temp -vv

Also tried:

rclone mount NAS: N: --vfs-cache-mode=full --no-check-certificate --file-perms=0777 --cache-dir=d:\temp -vv

The rclone config contents with secrets removed.

type = webdav
host = https://nas.local:5006
vendor = other
user = user
pass = ...

A log from the command with the -vv flag

open-7z-exe.log (56.4 KB)

Related posts

When you directly mount this webdav server (without rclone) does it work?

as a test, might try using
--- smb/samba
--- sftp
--- rclone serve webdav - rclone can emulate a simple webdav server.

can try two smb ways:

  1. use net use or windows explorer to mount N:
  2. create a rclone remote for smb -

i replicated your setup and tested two ways. so far, no problems at all. and in the past, never had an issue.

  1. with vfs cache
  2. without vfs cache

and for anybody else, here is my howto guide
How to run a .exe on a windows rclone mount

C:\data\rclone\rclone.exe mount synbox_webdav: N: --no-check-certificate --file-perms=0777

type = webdav
vendor = other
url =
port = 5006
user = user99
pass = -mSsSrsOJDUnClvWZBoZA-qe5WcQGGiL003m3CjP126oTxek
n:\zork>dir /b

n:\zork>7z dummy
7-Zip 22.01 (x64) : Copyright (c) 1999-2022 Igor Pavlov : 2022-07-15
Command Line Error:
Unsupported command:

FYI - I have tried it as well - but with other remotes - no issues at all with running 7z.exe and other binaries.

I would start with making sure that you have the latest WinFsp

tl;dr - use a subdir of /volume1, not root of /volume1
that is based on the assumption that the root dir of your mount is /volume1, same as in my case.

did more testing, so far, imho, looks like this is not a rclone issue.
the synbox does not want us to mess around in the root of /volume1
that is owned by root

in addition to webdav, rclone mount behaves the same using sftp and smb.
and same basic issue with filezilla and ssh

i could not replicate, as the synbox does not allow copying files in the root of volume1
sure, i got force it as root user, but not going to test that.

winfsp version: 2.0.23075

Can't understand what you said...

  1. create a subdir, for example, N:\exefiles
  2. copy 7z.exe to N:\exefiles
  3. run 7z.exe from N:\exefiles

It is not good practice to run executables from mounted NAS in general. Of course it is your system and you can do what you want. Store documents in "C:\Program Files" and programs on NAS. But doing such creative things you have to expect to deal with multiple problems all the time.

Sometimes life is easier when you stick to common conventions and standards - e.g. why to use rclone on Windows to mount webdav? When Windows can mount webdav on its own. You just add another extra element you have to configure and potentially misconfigure.

Seems that mount WebDAV directly on Windows via built-in support will have even more problems... For example, I can't even play videos with this way...

Highly possible that built-in webdav has some limitations - but it is not related to rclone. I would suggest to use smb/samba instead.

Mount SMB share folders with Rclone will have the same issue, just can't run binary files owned by admins...

Do you have the same issue with exactly the same files when you do not use rclone at all? You can create SMB share using your NAS web GUI and mount it directly on Windows without rclone.

No, it won't, it can open anything as expected.
However, you can only mount one specific share folder as a disk, rather than can mount all folders as one, as I replied in another post.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.