Blue screen when trying to access gdrive rclone mount on windows 10

Hello guys. I have a problem trying to mount my google drive account to a drive letter on my windows 10 box .
I regularly configured the access to my Google drive on rclone and I’m able to upload and download files from the command line, but whenever I try to mount it and assign it to a windows drive letter I can see the new disk appearing on explorer but as soon as I try to access it Windows just spit on my face a sad blue screen.

I’m using rclone v1.37 amd64 from a regular cmd prompt and I installed the winfsp installer after having downloaded it from the its official page.

Any ideas? Thank you in advance!

Can you take a screenshot of the blue screen - what does it say?

Hi !


I ran into a similar problem as I tried to mount my Google Drive to a drive letter on Windows 10. Instantly got a BSOD when accessing the mount.
The error seemed to come from the aswsnx.sys file which is part of Avast Free antivirus. This file in particular seems to be running a service for sandboxing files (and filesystems) and doing some kind of virtualization if I understand correctly (couldn’t figure it out completely).

Anyways the only solution I found for now was to uninstall Avast and switch to another anitvirus software.

Hope it helps, but difficult to say where it’s coming from without more information about this BSOD like @ncw said.

Actually I was waiting to finalize some opened jobs on my laptop in order to reboot the machine and make some new tests to trigger the blue screen but yes, moussor already found and explained the problem (thanks a lot).
Definitely it has to be connected with how avast works, that’s also the antivirus I’m using.

It would be great if one day this incompatibility could be solved (as I consider avast unintrusive enough for a free antivirus, but I’m also in the need of starting to use rclone on windows a well) but anyway I think that, for the moment, the fact that this incompatibility has been found out it’s already something. Maybe it could be useful if someone could document the issue on the github wiki (if it’s active and being used).

Thanks again.

Please see Rclone v1.37 release for my notes on this. I’ve also raised a github issue for WinFSP which is ongoing.

1 Like

@zaldre my apologies for not having had the time to look into this more closely. I am currently on vacation and with limited time and access to resources to properly troubleshoot this.

Is it possible to report this to Avast as well and see if they have an idea on this? Alternatively do they have public symbols somewhere?

@billziss-gh Hey mate no worries, I actually tried to log this with Avast on a number of occasions however was unable to as i’m not using the paid version of their products. A little unfortunate, but i’m hoping that someone on these forums that is a subscriber is able to provide more assistance. Fingers crossed!

Thanks for the understanding, @zaldre.

To all concerned: the related GitHub issue is here: Feel free to add any relevant information, especially if you have kernel dumps that might help us better understand the issue.

This also happens when using AVG Anti Virus. Same error message but with the AVG filename instead of the AVAST

Yep this doesn’t surprise me. AVG and AVAST are basically the same thing these days since the buyout of AVG.

I have started looking into this and have some initial analysis at GitHub. I have also contacted Avast in the hope that they will help with resolution.

I have finally received a response from Avast. I will keep you posted on any resolution.

1 Like

This problem is now fixed in the WinFsp master branch. The fix will be included in the v1.2B2 release, hopefully out sometime next week.

1 Like

Fantastic news :smile:

WinFsp v1.2 second beta is out and includes the AvastAV BSOD fix plus some other fixes and improvements. I encourage people to try it, especially those who had problems with Avast+WinFsp before.

Caveat: this beta does not work on Server 2016, because I have not had it digitally signed for this platform. The process of signing WinFsp for Server 2016 is very involved and for this reason I only do it for final (i.e. non-beta) releases.

Link to WinFsp releases: