Beta Testing: WebGUI for rclone

Web-based GUI for rclone is finally here.

As many of you might have noticed a new project under rclone. The rclone-WebUI-react.
We were in the process of developing a low weight web-based UI for interacting with the rclone. I am happy to announce that we are finally inviting beta testers for this project. :grinning:

To get started,
First of all

Update rclone to the latest beta version.

You can now launch the WebGUI using the following commands:

rclone rcd --rc-web-gui --rc-user=<username> --rc-pass=<password> --rc-serve

--rc-serve enables you to download files using the WebGUI.

The --rc-web-gui option will enable you to visit the WebGUI at the default URL of rclone.

The WebGUI doesn't allow being used without authentication. So, rc-user and rc-pass are not optional. rclone will automatically download the latest release of the WebGUI for you.

--rc-serve enables you to download files using the WebGUI.

Issues

The project URL for rclone-webui-react is https://github.com/rclone/rclone-webui-react.
Please feel free to open issues or feature requests.
Please post the WebGUI related issues on this repository instead of the rclone's original repo.

10 Likes

Welcome to the rclone community @negative0 :smiley:

@negative0 has been working on this as a Google Summer of Code project. There are a couple of weeks left to run so we'd like user testing and bugs reported please, though bear in mind we haven't got time for a major redesign though right now!

I imagine we'll make starting the GUI easier at some point from rclone, this is the first iteration.

2 Likes

Thanks for the introduction @ncw :grinning:. It has been a pleasure working on this project.

2 Likes

thanks but it does not work as it should, maybe because its beta,
there are often some JSON write errors in console,

rc: failed to write JSON output: write tcp 127.0.0.1:5572->127.0.0.1:65050: wsasend: connection broke by end host
and have to refresh...

often when i click on file it only says:
Downloading 7 file(s). Please wait.

and nothing happens.
so i will have to wait patiently i guess....but concept is great,
i hope in future this webgui will have builtin movie player with subtitles....

nice feature also would be to have direct link to file,
like:
http://localhost:5572/[gdrive:videos]/1vid1.mp4

That is a local connection error. Did rclone die at this point? Do you have a firewall which might be blocking local connections?

no, did not die.
I do it all on localhost pc, on chrome browser.
so on my pc with windows i run rclone rcd --rc-web-gui --rc-user=chaitanya --rc-pass=abcd --rc-serve and rclone says me to go to http://127.0.0.1:5572 and i go there.
There are 2 login forms, first is login form as in web authentication, second login form is from webui react interface.
I type user, pass,
go to backends,
cmd console asks me for password to encrypted config
i type password for rclone.conf to decrypt,
now i go to explore and choose for example gdrive
now cmd console shows me this error JSON,
and i wait and nothing happens,
so i refresh website and now it correctly shows files.

Wow, awesome! I will totally be checking this out and helping to bughunt and make improvement suggestions :slight_smile:

A proper webGUI will go a very long way to making rclone more accessible and easier to work with.

Rclone is not able to handle when the receiver -> (WebGUI) cancels the request by operations like refreshing. Thus, the error connection broke. Let's see what we can do about that. Maybe continue from where the download was cancelled. :slight_smile:

About the movie player, we already have that, but sadly no subtitles support yet. Maybe add it as a feature request?. There are two things you need to do to see it.
In the remote explorer:

  1. More -> View Type -> Grid.
  2. More -> Tick the load images checkbox.
    Check the image for details:

Screenshot%20from%202019-08-06%2018-33-00

Wow, Thanks :grinning:

I've recently pushed some fixes for this to the latest beta which should be available in 15-30 mins.

  • fixed browser window not opening (this will fix having to log in twice!)
  • fix permissions in cache directory. You might need to delete ~/.cache/rclone/webgui/
  • removed -w flag
1 Like

tried laest beta, and still, when i do explore backend, it says
rc: failed to write JSON output: write tcp 127.0.0.1:5572->127.0.0.1:50280: wsasend: connection ended by host

ok, when i click load images, and try to play some video in browser, it shows another login form, like http login to enter username and password again.

And clicking many files generates lot of json errors.

The is rclone saying that the web browser closed the connection

Did you press the refresh button on the browser?

I couldn't reproduce your problems with chrome/linux

Good job! Great! Thanks
I know that is really beta, still..but I inform of my issue
I tried locally in my laptop, with Mint, and ti starts well and I can connect via web... then I tried in Synology, it starts without any error, but its impossible to access with the remote IP... I believe, it only answers in "127.0.0.1", local IP, and not in "remote" one, like "192.168.0.x"

Yes. That is a security feature. I am working on a feature flag that will allow you to change the CORS- allow origin feature via the command line. It should allow you to change the allowed origin for requests.

1 Like

Great.... thanks

Nice initiative.
Are you needing contributions?

Contributions always welcome :slight_smile: I suggest you open an issue and sketch out what you want to contribute before sending a pull request (unless it is just a tiny fix!)

Error connecting. Please check username password and verify if rclone is working at the specified IP.

current version does not accept password and username, although i type it correctly always says error.

edit, its ok when i change localhost to 127.0.0.1 in webgui address above username pass