Zoho WorkDrive no items found in Workspace ID

What is the problem you are having with rclone?

When creating the config for Zoho WorkDrive, after I authorize through the browser and select a team, I get the message "Error: no items found in: Workspace ID". Any attempts to access the remote afterwards yields a 401 Unauthorized error. The browser authorization shows a success message, and config is able to correctly list the team drives I have access to. I've tried this on both my local machine and a virtual machine, with the same results. I get the same error regardless of the team drive I select. I have WorkDrive through a Zoho Workplace Professional license. If it's relevant, I am also part of an organization where I have admin access, but I am not the super admin.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.0-beta.6147.b929a56f4
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.18.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Zoho WorkDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config
rclone lsd remote:

The rclone config contents with secrets removed.

type = zoho
region = com
token = {"access_token":[[redacted]],"token_type":"Zoho-oauthtoken","refresh_token":[[redacted]],"expiry":"2022-05-16T11:49:55.6330496-04:00"}

A log from the command with the -vv flag


hello and welcome to the forum,

best to test using stable rclone, v1.58.1, not the beta.


I've had exactly the same result with stable, and I switched to the beta to see if that fixed the problem.

What that means is that rclone tried to look up your workspace IDs and didn't find any, so couldn't complete the configuration.

If you know the ID then you can put it in your config

root_folder_id = XXXX

And things should start working.

Can you run rclone config -vv --dump bodies and run through the config again.

Can you post the last HTTP transaction so the request for /teams/XXX/workspaces and the corresponding response and hopefully we can get to the bottom of this.

Feel free to redact any information you think might be confidential.


Thank you for your response!

So, here's everything from the point where I set the team drive ID to where it gives the error. It's a 200 OK response, but the expiration date seems off.

config_team_drive_id> 2
2022/05/17 10:08:44 DEBUG : [[redacted]]: config in: state="workspace", result="[[redacted]]"
2022/05/17 10:08:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2022/05/17 10:08:44 DEBUG : HTTP REQUEST (req 0xc0005b7200)
2022/05/17 10:08:44 DEBUG : GET /api/v1/teams/[[redacted]]/workspaces HTTP/1.1
Host: workdrive.zoho.com
User-Agent: rclone/v1.59.0-beta.6147.b929a56f4
Accept: application/vnd.api+json
Authorization: XXXX
Accept-Encoding: gzip

2022/05/17 10:08:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2022/05/17 10:08:45 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/05/17 10:08:45 DEBUG : HTTP RESPONSE (req 0xc0005b7200)
2022/05/17 10:08:45 DEBUG : HTTP/2.0 200 OK
Cache-Control: private,no-cache,no-store,max-age=0,must-revalidate
Content-Type: application/vnd.api+json;charset=UTF-8
Date: Tue, 17 May 2022 14:08:44 GMT
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Pragma: no-cache
Server: ZGS
Set-Cookie: 9eb55d8a61=bd8464a6ae1f85532df086d0cab5f625; Path=/
Set-Cookie: zpcc=f1aaee60-be31-423e-8ee5-0e3184a9e71c;path=/;SameSite=None;Secure;priority=high
Set-Cookie: _zcsr_tmp=f1aaee60-be31-423e-8ee5-0e3184a9e71c;path=/;SameSite=Strict;Secure;priority=high
Set-Cookie: JSESSIONID=E9B4BF9429547929AA9E3385D62BF8A7; Path=/
Strict-Transport-Security: max-age=63072000
Vary: accept-encoding
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-Xss-Protection: 1

2022/05/17 10:08:45 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/05/17 10:08:45 DEBUG : [[redacted]]: config out: out=<nil>, err=no items found in: Workspace ID
Error: no items found in: Workspace ID

Looks like something went wrong here! We aren't caching it, so I don't think it matters.

It seems to be saying that that user doesn't have access to any workspaces. Could that be true?

Can you find out the workspace ID independently and stick it in the config as root_folder_id = XXXX and see if that works?

@buengese are you on here? Have you any ideas?

It turns out the issue is that I was expecting the WorkDrive implementation to work differently than it actually does.

I didn't have any Team Folders set up, because we're still working how to set those up within our organization. So, I set up a team folder "Test", the id for that was detected successfully, and everything works as it should. I'm guessing that means different team folders have to be set up as different remote drives, then. It also doesn't seem possible to access or do anything with my personal drive files, although that's unnecessary for the specific application I'm looking to use rclone for.

Glad you got it working.

You can pass the workspace id as a parameter or set up aliases which change the root folder Id parameter.

This seems very similar to the Google teamdrive situation so the sales solutions will work here

Don't they appear as a workspace? I only have a free Zoho account which doesn't have many features!

No, it doesn't seem to show up as a workspace, which is why I was having issues with rclone not being able to find workspaces. I found this API documentation, and it seems like getting "My Folders" is a different process where you need a team member id, and then it's [team member id]/privatespace

Ah, OK. So presumably if you could find the ID you could stick it into the root_folder_id and rclone would just work.

Maybe rclone needs a bit of extra config for this so it looks at "my folders" too?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.