Yet another problem with Crontab

Hello guys, I having still problems with crontab and even after reading many threads about this same problem I could not make rclone working.
I want to copy some folders to onedrive.

Here my crontab:

30 11 * * * /usr/bin/rclone copy --config=/home/mx520/.rclone.conf /media/mx520/HDD2/Backup1 onedrive:Backup_rclone

Based on past posts, I made sure I have the right full path to rclone and also to point to the right config file, but still no success.

I have also tried it setting that crontab for root, but still not working.

I am not sure I need a script for that simple command and also -frankly- I would have to study how to make it as I am not expert at all lol

Thanks for your support.

Does it run from the command line ok?

You can add a log file to it by making it:

30 11 * * * /usr/bin/rclone copy --config=/home/mx520/.rclone.conf /media/mx520/HDD2/Backup1 onedrive:Backup_rclone > /tmp/rclone.log 2>&1

That basically captures all the output from stdout and stderr and put it into a log file in /tmp

If it runs the command line, add that and share the log.

It did not work from command line, log showed a misconfiguration of the remote, recommending to create it again from scratch. I did it and not it works from command line.
So tonight I set it as a cronjob and I report back later if it works or not.