Windows weird/bad optimization compared to Ubuntu. HDD high activity

Hi, it seems rclone doesn’t work well with windows.

Here is the problem. I’m downloading from google drive to my local SSD (500gb samsung evo).

  1. Speeds are good going up to 900Mb/s
  2. Files are 2gb each and using --transfers=1
  3. When each file finishes, rclone will do something that causes HUGE disk activity, assuming writing to drive.
  4. This dampens speed back to 0Mb/s and jump back to 900Mb/s

Then it got me wondering, maybe its my ssd going bad. Ok… Now i try to download to my 2tb 7200rpm Firecuda SSHD.

Same outcome as my SSD. High disk activity at the end of file completion.
Look here to see the graph going up and down, <Also look at the speeds and disk activity.

Then, I tried to boot up my ubuntu 16.04 using Kingston V300 120gb SSD and replicate the process writing to both 500gb samsung evo and 2tb 7200rpm Firecuda SSHD . Since there is no native disk activity tool, i just look at the inbuilt ubuntu network monitor speeds, NOT rclone speeds, to check real-time.

To my surprise both tests downloded smoothly, 800-900Mb/s. The network graph had no dips at all meaning no jumps from 0-900 vice-versa. Hence, the way it writes to the disk is totally different from windows.

Using latest version of rclone 1.35 for both.
Any solution for windows?

Can you try rclone 1.36 please? It is possible that the buffering changes have fixed this.

Can you also see if using different values for --buffer-size helps?

If the problem persists, please report an issue on github with the above information.



Same problem with 1.36 on windows but works great on ubuntu. Tried --buffer-size 1G, same problem. Yes, i've posted it on github as requested.

Thanks for making the ticket. I’ll respond there.