Windows scheduled task not running automatically

What is the problem you are having with rclone?

Hi! I tried following the other threads on this forum regarding how to automatically copy or sync files to a remote using Window's task scheduler, but I cannot seem to get it to work no matter what I tried. Running the scheduled task manually will trigger the action that copies the files to the remote, but the scheduled task does not run automatically.

Below are some screenshots of the settings I set for the scheduled task I created:

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1
- os/version: Microsoft Windows 11 Pro 22H2 (64 bit)
- os/kernel: 10.0.22621.2134 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.20.6
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive and OneDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

This is the rclone.cmd that I set in the action tab of the scheduled task

cd C:\Users\churi\rclone
rclone.exe copy "C:\Users\churi\Documents" gdrive-crypt:"Documents" --config="C:\Users\churi\AppData\Roaming\rclone\rclone.conf" --log-file="C:\Users\churi\rclone\rclone.log" --log-level="INFO"
rclone.exe copy "C:\Users\churi\Documents" onedrive-crypt:"Documents" --config="C:\Users\churi\AppData\Roaming\rclone\rclone.conf" --log-file="C:\Users\churi\rclone\rclone.log" --log-level="INFO"

The rclone config contents with secrets removed.

type = drive
client_id = secret
client_secret = secret
scope = drive
token = {"access_token":"secret","token_type":"Bearer","refresh_token":"secret","expiry":"secret"}
team_drive = 

type = onedrive
client_id = secret
client_secret = secret
token = {"access_token":"secret","token_type":"Bearer","refresh_token":"secret","expiry":"secret"}
drive_id = secret
drive_type = personal

type = crypt
remote = gdrive:Private
password = secret
password2 = secret

type = crypt
remote = onedrive:Private
password = secret
password2 = secret

A log from the command that you were trying to run with the -vv flag

The scheduled task does not run automatically, so nothing shows up in the log file. If I manually run the scheduled task, then I will see something like this in the log file:

2023/09/06 16:16:05 INFO  : KeePass/recipes.kdbx: Copied (replaced existing)
2023/09/06 16:16:05 INFO  : KeePass/Backups/recipes.20230906153244.kdbx: Copied (new)
2023/09/06 16:16:10 INFO  : 
Transferred:   	  113.428 KiB / 113.428 KiB, 100%, 18.659 KiB/s, ETA 0s
Checks:               631 / 631, 100%
Transferred:            2 / 2, 100%
Elapsed time:         9.2s

Thanks for taking the time to read this.

welcome to the forum,

have you tested without rclone, using very simple command.
for each run, this command appends current timestamp to file.
cmd /c echo %time% /t >> c:/full/path/to/output.txt

Hi! Thanks for responding so quickly. I tried to change the scheduled task's action as you suggested like so:

but the scheduled task still does not run automatically. It only runs when I manually click on the 'Run' button as seen in the scheduled task's history tab:

and after I manually run the scheduled task, I can see this in the log file:

17:46:45.52 /t 

but I do not know why it doesn't run automatically no matter what combination of settings I try.

Deleting the scheduled task and recreating it fixed the issue :confused: Thanks for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.