Windows rclone directory listing issue

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here
.\rclone.exe lsd mystorage

#### The rclone config contents with secrets removed.  
<!--  You should use 3 backticks to begin and end your paste to make it readable.   -->

Paste config here

Remote config

type = s3
provider = AWS
env_auth = false
access_key_id = XXXXXXX
secret_access_key = XXXXXXX
region = eu-central-1
location_constraint = EU
storage_class = STANDARD

A log from the command with the -vv flag

Paste  log here
PS C:\rclone> .\rclone.exe lsd my-image
2021/09/10 11:25:33 ERROR : : error listing: directory not found
2021/09/10 11:25:33 Failed to lsd with 2 errors: last error was: directory not found

You are missing the : following the remote name, so rclone treats it as a local, relative path instead.

Try something like this, assuming your configured remote is called "mystorage":

.\rclone.exe lsd mystorage:

Thank you for your reply,
It looks like that also missed the / at the end of the command,
this works for me:
.\rclone.exe lsd mystorage:/

I try to run the rclone as Windows 2019 service, I use the nssm, serive get added but unable to start the service.
any idea how to get the rclone to run at the background even when user logged out?


Wouldn't think that was necessary, and it is even preferred not to as per docs:

Create a scheduled task with Windows Task Scheduler, or a service with PowerShell New-Service or third party tool NSSM, WinSW etc. Run as the built-in SYSTEM user account.

in addition to what @albertony wrote.

also, i suggest using windows built-in task scheduler, has a nice gui, can start any application, not just rclone.
and if you are having issues running rclone as a service,

  1. when running as a service, rclone is running in the background, so use a debug log file.
  2. hard code all file paths, as when the script runs, it might run as system user.
  3. rclone lsd, since rclone is running in the background, you will not see the output so redirect it.
    try c:\path\to\rclone.exe lsd mystorage: --config=c:\path\to\rclone.conf --log-file=c:\path\to\rclone.log > c:\path\to\output.txt
  4. get the command working on the command first, then try it as a service..

As I menationed, I used the nssm and I can see the service get added to the services, but service wont start, it looks like my argument is not correct, I use this one for my AWS S3:
mount mydrive/ s: --config “C:\rclone\rclone.conf”

Any suggestion on what is the correct argument? or any document on how to run the rclone even when user logged out?

get the command working on the command first, then try it as a service..

:+1: :+1: :+1:

Colons must be fixed, again. E.g. :

mount mydrive: s: --config C:\rclone\rclone.conf

There are some documentation here (I forgot):

This is the command that I run and my S3 get mounted to my server 2019 and can move files between them, but for some reason wont work as a service.

mount my-storage:my-storage/ S: --vfs-cache-mode full

If I use my-storage: wont work at all!!
I also tried the powershell option New-service but again service added to win services but wont start and go to pause!!!

pehaps @albertony could answer.

did not mean to push myself into this...

Anything in Windows event logs regarding the service?
Try without the --vfs-cache-mode option, simplest possible command - but add --log-file and see if it creates the log file and writes anything at all to it. Another possibility is the psexec utility, as mentioned in the install docs, to run on manually on command-line - but as system user, in case it is related to that somehow.

No worries at all, just join in if you have ideas!


the easiest way to get this done is task scheduler and its nice and friendly user interface.

as for psexec, here is an example

d:\data\u\sysinternals\psexec -i -s "c:\data\rclone\scripts\command.cmd"


cd /d C:\data\rclone\scripts
whoami > output.txt
rclone.exe version >> output.txt

here is the output.txt

nt authority\system
rclone v1.56.0
- os/version: Microsoft Windows 10 Pro 2009 (64 bit)
- os/kernel: 10.0.19043.1165 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.16.5
- go/linking: dynamic
- go/tags: cmount

Thank you, I will try your suggestion and keep you posted.
I see the same masseg in event logs and nothing that can be use to troubleshooting this issue!!

Does this also keep the drive mounted when no user is logged? I have a application the should use the mounted S3 storage!
Thank you both for your assistance!

given that the rclone mount is run as system, i believe the answer is yes.
tho i have not tested that.
if you test that, let us know.

if the computer is rebooted, need to run the command again...

There is a task trigger for "system startup", in addition to "user log on". So (assuming running as system user), I would think that should keep the mount running at "all times"..?

that is correct for task scheduler.

i thought the OP was asking about psexec?

Aha, that could be true.
(I was thinking psexec only for investigation. Taskscheduler or service for permanent setup.)


given how easy it is to start a task via task scheduler, i have not used psexec in a while.
from from the command line
schtasks.exe /run /tn "rclone\rclonemount"
and that task will run as system

also can use that with a .lnk file to have an icon shortcut.


Hi guy's
It looks like that I got the rclone running as a service on my server 2019, but I have a strange issue,
When running the service I can see that drive get mounted, but when right click in mounted drive to create an folder I can see 4 folders get created

Also when mount the same storage on Windows 10 I cannot see the newly created folders and when create folder on the windows 10 it got once created but I cannot see this folder on the server 2019.

Any suggestion?


This is an issue that has been observed in the past, but I don't remember if there was a conclusion..

I don't have time to investigate it at the moment, but you can read through the following issues, and try a search in forum and on github, and perhaps you are able to find relevant information:

PS: Seems the first thing to try, when running rclone as system user, is to set your own user as owner of the mounted filesystem:

-o UserName=user123 -o GroupName="Authenticated Users"
(see rclone mount docs)