Windows mounted WebDAV drive has no free space?


#1

I mounted a MagentaCLOUD account (https://www.magentacloud.de/) using WebDAV.
The drive shows 0byte free in Explorer and copying to the drive doesn’t work.
Copying files to the drive using “rclone copy file magenta:” works.
Mounting a OneDrive correctly shows the free space and copying files there works.

Is there anything I am doing wrong or is this a incompatibility with MagentaCLOUD?


#2

What does

rclone about yourremote:

say?

Which version of rclone are you using? If you aren’t using the latest then try the the latest release.


#3

$ rclone about magenta:
Total: 0
Used: 0

rclone v1.46

  • os/arch: windows/amd64
  • go version: go1.11

#4

Hmm, so magenta seems to think that you have a total allocation of 0, or maybe rclone is reading it wrong.

Can you try

rclone about magenta: -vv --dump bodies

Then we can see exactly what magenta is sending.

Perhaps I should ignore Total if it is 0… Is the size 0 correct? As in you have no files uploaded?

You can work-around this with --disable About which will cause rclone to believe that magenta doesn’t support the about call.


#5

Sorry for the late answer, I was sick for a few days unfortunately.

Here is the output:

$ rclone about mc: -vv --dump bodies
2019/03/13 20:45:35 DEBUG : rclone: Version "v1.46" starting with parameters ["rclone" "about" "mc:" "-vv" "--dump" "bodies"]
2019/03/13 20:45:35 DEBUG : Using config file from "C:\\Users\\User\\.config\\rclone\\rclone.conf"
2019/03/13 20:45:35 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2019/03/13 20:45:35 DEBUG : HTTP REQUEST (req 0xc000487200)
2019/03/13 20:45:35 DEBUG : PROPFIND / HTTP/1.1
Host: webdav.magentacloud.de
User-Agent: rclone/v1.46
Content-Length: 139
Authorization: XXXX
Depth: 0
Accept-Encoding: gzip

<?xml version="1.0" ?>
<D:propfind xmlns:D="DAV:">
 <D:prop>
  <D:quota-available-bytes/>
  <D:quota-used-bytes/>
 </D:prop>
</D:propfind>
2019/03/13 20:45:35 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2019/03/13 20:45:35 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2019/03/13 20:45:35 DEBUG : HTTP RESPONSE (req 0xc000487200)
2019/03/13 20:45:35 DEBUG : HTTP/1.1 207 Multi-Status
Content-Length: 307
Content-Type: text/xml; charset="utf-8"
Date: Wed, 13 Mar 2019 19:45:32 GMT
Ms-Author-Via: DAV
Server: Apache/2.2.20 (Unix) DAV/2 mod_ssl/2.2.20 OpenSSL/0.9.8x mod_perl/2.0.4 Perl/v5.10.1
Strict-Transport-Security: max-age=31536000; includeSubDomains

<?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:D="DAV:" xmlns:ns0="DAV:">
<D:response xmlns:g0="DAV:">
<D:href>/</D:href>
<D:propstat>
<D:prop>
<g0:quota-available-bytes/>
<g0:quota-used-bytes/>
</D:prop>
<D:status>HTTP/1.1 404 Not Found</D:status>
</D:propstat>
</D:response>
</D:multistatus>
2019/03/13 20:45:35 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Total:   0
Used:    0
2019/03/13 20:45:35 DEBUG : 4 go routines active
2019/03/13 20:45:35 DEBUG : rclone: Version "v1.46" finishing with parameters ["rclone" "about" "mc:" "-vv" "--dump" "bodies"]

Mounting with --disable About leads to 1PB free space shown in explorer and copying files to the drive works.


#6

Rclone is interpreting this as 0 available bytes, but I think it should be ignoring them

That is easy enough to fix - can you try this for me?

https://beta.rclone.org/branch/v1.46.0-070-ga85897e6-fix-webdav-about-beta/ (uploaded in 15-30 mins)


#8

Thank you.
But this doesn’t seem to change anything:

$ rclone version
rclone v1.46.0-070-ga85897e6-fix-webdav-about-beta
- os/arch: windows/amd64
- go version: go1.11

$ rclone about mc:
Total:   0
Used:    0

Deleting and reconfiguring the remote also doesn’t seem to change anything.

I can give you login data to a free account there if this helps?


#9

Hmm I see my mistake.

Try this

https://beta.rclone.org/branch/v1.46.0-070-g52a99a62-fix-webdav-about-beta/ (uploaded in 15-30 mins)


#10

This one works! It shows free space as 1PB and copying files to the drive works, just like with --disable About

Thank you very much!


#11

Thanks for testing :smile:

I’ve merged this to master now which means it will be in the latest beta in 15-30 mins and released in v1.47