Windows Mount Backblaze B2

What is the problem you are having with rclone?

Mounting Backblaze B2 and copying files to it
Mount seems to work but copying files fails

What is your rclone version (output from rclone version)

rclone v1.53.1

  • os/arch: windows/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 x64

Which cloud storage system are you using? (eg Google Drive)

Backblaze B2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount Backblaze Y:

The rclone config contents with secrets removed.

type = b2
account = xxx
key = xxx

A log from the command with the -vv flag


Looks like to be solved with:
rclone.exe mount --vfs-cache-mode writes Backblaze Y: -o volname=local

Still does not work
I used
rclone.exe mount --vfs-cache-mode writes Backblaze:usefulviddemo1 Y: -o volname=local
But I can not delete files:

2020/09/27 23:32:42 DEBUG : fs cache: switching user supplied name "\\\\?\\C:\\Users\\usefulvid\\AppData\\Local\\rclone\\vfs\\Backblaze\\usefulviddemo1" for canonical name "//?/C:/Users/usefulvid/AppData/Local/rclone/vfs/Backblaze/usefulviddemo1"
2020/09/27 23:32:42 DEBUG : B2 bucket usefulviddemo1: Mounting on "Y:"
2020/09/27 23:32:42 DEBUG : B2 bucket usefulviddemo1: Mounting with options: ["-o" "fsname=Backblaze:usefulviddemo1" "-o" "subtype=rclone" "-o" "max_readahead=131072" "-o" "attr_timeout=1" "-o" "atomic_o_trunc" "-o" "uid=-1" "-o" "gid=-1" "--FileSystemName=rclone" "-o" "volname=Backblaze usefulviddemo1" "-o" "volname=local"]
2020/09/27 23:32:42 DEBUG : vfs cache RemoveNotInUse (maxAge=3600000000000, emptyOnly=false): item rclone.exe not removed, freed 0 bytes
2020/09/27 23:32:42 DEBUG : vfs cache RemoveNotInUse (maxAge=3600000000000, emptyOnly=false): item test.txt not removed, freed 0 bytes
2020/09/27 23:32:42 INFO  : vfs cache: cleaned: objects 2 (was 2) in use 0, to upload 0, uploading 0, total size 40.096M (was 0)
2020/09/27 23:32:42 DEBUG : B2 bucket usefulviddemo1: Init:
2020/09/27 23:32:42 DEBUG : B2 bucket usefulviddemo1: >Init:
2020/09/27 23:32:42 DEBUG : /: Statfs:
2020/09/27 23:32:42 DEBUG : /: >Statfs: stat={Bsize:4096 Frsize:4096 Blocks:274877906944 Bfree:274877906944 Bavail:274877906944 Files:1000000000 Ffree:1000000000 Favail:0 Fsid:0 Flag:0 Namemax:255}, errc=0
2020/09/27 23:32:42 DEBUG : /: Getattr: fh=0xFFFFFFFFFFFFFFFF
2020/09/27 23:32:42 DEBUG : /: >Getattr: errc=0
2020/09/27 23:32:42 DEBUG : /: Readlink:
2020/09/27 23:32:42 DEBUG : /: >Readlink: linkPath="", errc=-40
The service rclone has been started.

Even with
rclone.exe mount --vfs-cache-mode full Backblaze:usefulviddemo1 Y: -o volname=local

it looks like it works but no files arrive at my bucket.

hello and welcome to the forum.

sorry but i am confused with all those edits - you can just add a new post instead of editing old posts.

what is the problem?
that you cannot copy files?
you cannot delete files that were copied?

The problem is here:

2020/09/27 21:58:41 DEBUG : rclone: Version "v1.53.1" starting with parameters ["rclone.exe" "mount" "Backblaze" "Y:" "-vv"]

You need to use Backblaze: rather than Backblaze otherwise you are using a local directory called Backblaze rather than your cloud storage remote called Backblaze:

You are right I corrected my first post already:

I save a file in the mounted directory but its not visible on my B2 storage webinterface "browse files" section

  • how are you copying the files from local to backblaze?
    windows explorer or what?

  • does rclone ls Backblaze: produce the expected output?

  • if you copy local files to backblaze without the mount using rclone copy, do you seem those files.

  • for each command, you should use debug output using -vv

  • try a simpler mount command and test copying files
    rclone.exe mount Backblaze:usefulviddemo1 Y: -vv


yes, files I copied via explorer are visible

Just solved the mystery.
The b2 webinterface only shows the files if I log out and in again. reloading the page did not show new files.
Thanks for your help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.