Windows max path lengh

https://pastebin.com/chSnEQ2M
you mean

D:\rclone\rclone.exe mount gcrypt:crypt G: -vv --fuse-flag --VolumePrefix=\cloud\media2

because without it is not mounted in windows as a network dirve :wink:

in the logs you keep posting, are there any errors???

i gave you my suggestion, for testing, to simplify the command as much as possible.
if you do not want to try it, not sure what more i can help you with.
rclone.exe mount gcrypt:crypt G: -vv and do something to generate some errors.

https://pastebin.com/3E9neAih

wow now it want to work with both... it works with as a network drive and it works not as a network drive....
why??? i try more

so it is working now?

what commands are working now?

I'm extremely confused right now. it seems that the --vfs-cache-mode is the problem. my confusion comes from the fact that i took it out in the beginning for testing purposes and it didn't work there

it was at cahce mode minimal, now i changed for testing to write and now it dont want to start anymore... :tired_face: :tired_face: :tired_face:

edit: forgot the s at writes -.-

perhaps as i suggested, remove as many flags as possible and test.
you need to understand a flag before you use it.

for example,
--cache-db-purge is not needed, as it for cache backend.
--allow-non-empty does nothing on windows, as per the documentation.

already throw out non empty

but db purge... why not?

Clear all the cached data for this remote on start.

okay cache mode off is working... but minimal, writes and full not.. why? i already enabled "Enable win32 long paths" inside the GPO...???

That's for the cache backend and is not related to the VFS caching setup.

1 Like

still not sure what, exactly, you are trying to do and what the exact error is?

are you trying to copy a .rar file from local to gcrypt?
or
are you trying to create a new .rar on the g:?

I trying to copy data from local to remote (google).
At the moment vfs cahce modde is beeing used it copy the files first to a local directory the problem is at this moment the path/file name comes over 260. Normally it should work because i edited in gpo that a file path longer than 260 is allowed. but it looks like rclone cant handle these

if you are copying files, then you do not need vfs.
but i find on windows, that adding --vfs-cache-mode=minimal speeds up the copying process.

try copying the file direct to gcrypt: without using the mount.

as per the documenation,
https://rclone.org/docs/#windows

what im doing wrong atm -.-

it will not accept the cache mode

no need for that flag, remove it.
just as cache-db-purge is for the cache backend.
so vfs-cache-mode is only for mount, and you are not using the mount.

no, without the / its not working either

no need for that flag, remove it.
just as cache-db-purge is for the cache backend.
so vfs-cache-mode is only for mount, and you are not using the mount.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.