Windows max path lengh

What is the problem you are having with rclone?

if i want to upload files into my backup (mounted with crypt and cache) the path/file length is going over 260 letters. The output of the command line "cache open file failed: The system cannot find the path specified" the output of windows is that there is an E/A error with the drive (uploaded the picture at bottom). the problem is i already allowed paths over 260 in GPO...
when i upload data to the folder below and move them to the correct folder This is going.
i already tried to mount the network drive a folder below the destination directory but it didn't worked either.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 pro/education have the problem at 3 machines

Which cloud storage system are you using? (eg Google Drive)

google drive -> cache -> crypt

The command you were trying to run (eg rclone copy /tmp remote:tmp)

D:\rclone\rclone.exe mount gcrypt:crypt F: --fuse-flag --VolumePrefix=\cloud\media --cache-db-purge --allow-non-empty --buffer-size 32M --use-mmap --dir-cache-time 72h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret = XXXXXXXXXXXXXX
scope = drive
root_folder_id = XXXXXX-XXXXXXXXX
token = {"access_token":"XXXXXXXXXXXXXXXXXX-XXXXXXXXXXXXXXXX-","token_type":"Bearer","refresh_token":"1//XXXXXXXXXXXXXXXXXXXX-XXXXXXXXX-XXXXXXXXXXXXXXX-XXXXXXXXXXX","expiry":"2020-06-21T14:04:34.1702063+02:00"}

type = cache
remote = gdrive:
chunk_size = 10M
info_age = 1d
chunk_total_size = 10G

type = crypt
remote = gdcache:
filename_encryption = obfuscate
directory_name_encryption = true

A log from the command with the -vv flag


With the file names and such removed, it's hard to tell what the issue would be.

Does it work without the cache on a regular mount?

i used for removing the notepad find and replace all option. i looked that the xx yyy and so on have the same File/Path length
i have now google drive -> crypt but it happens again. i think it happens, because i have to activate --vfs-cache-mode to can write into the mount. without i get a error and have to activate it

If you want to keep using Windows's file system you can try this: on the Local Group Policy Editor (gpedit.msc), in the left-hand pane, go down to Computer Configuration > Administrative Templates > System > Filesystem. On the right, find the “Enable win32 long paths” item, double-click it and enable it. This should work on Windows 10 Pro, not sure about education edition but try it.

Using mount to upload files (on windows) gives these kind of problems, You can use rclone itself (rclone commands) to move/copy/remove actions (even locally on your system).

You do not need any extra to read from the mount. If you can post a debut log, that would be all I need to see.

--vfs-cache-mode is not needed to copy files from local to cloud using a mount.
tho on windows, it does speed up the copy operation.
note that the flag has nothing to do with the cache backend.

--allow-non-empty does nothing on windows.

you need to post the debug log, add -vv to the command and post the output
and post the updated config file, redacting private info.

Enable win32 long paths
Already activated same problem

Log of other folder hierarchy same problem:
log.txt (899.0 KB)

is there a rclone error in that log.txt?

we need to see the top of the log with the command you can.
we need to see the updated config file, private into redacted.


type = drive
client_id =
client_secret = XXXXXXXXXXXX
scope = drive
root_folder_id = XXXXXXXXXXXXXX
token = {"access_token":"XXXXXXXXX","token_type":"Bearer","refresh_token":"1//XXXXXXXXXXXXXXXX","expiry":"2020-06-21T19:07:32.664544+02:00"}

type = cache
remote = gdrive:
chunk_size = 10M
info_age = 1d
chunk_total_size = 10G

type = crypt
remote = gdrive:
filename_encryption = obfuscate
directory_name_encryption = true

top of log when i start the mount:

is there an error in the log file?

2020/06/21 18:52:35 NOTICE: --allow-non-empty flag does nothing on Windows

can you do a rclone.exe lsd gcrypt:crypt, post the command and output

i suggest that you simplify the command as much as possible and try again.
rclone.exe mount gcrypt:crypt G: -vv
you mean

D:\rclone\rclone.exe mount gcrypt:crypt G: -vv --fuse-flag --VolumePrefix=\cloud\media2

because without it is not mounted in windows as a network dirve :wink:

in the logs you keep posting, are there any errors???

i gave you my suggestion, for testing, to simplify the command as much as possible.
if you do not want to try it, not sure what more i can help you with.
rclone.exe mount gcrypt:crypt G: -vv and do something to generate some errors.

wow now it want to work with both... it works with as a network drive and it works not as a network drive....
why??? i try more

so it is working now?

what commands are working now?

I'm extremely confused right now. it seems that the --vfs-cache-mode is the problem. my confusion comes from the fact that i took it out in the beginning for testing purposes and it didn't work there

it was at cahce mode minimal, now i changed for testing to write and now it dont want to start anymore... :tired_face: :tired_face: :tired_face:

edit: forgot the s at writes -.-

perhaps as i suggested, remove as many flags as possible and test.
you need to understand a flag before you use it.

for example,
--cache-db-purge is not needed, as it for cache backend.
--allow-non-empty does nothing on windows, as per the documentation.

already throw out non empty

but db purge... why not?

Clear all the cached data for this remote on start.

okay cache mode off is working... but minimal, writes and full not.. why? i already enabled "Enable win32 long paths" inside the GPO...???