Windows - local system mount - permissions

What is the problem you are having with rclone?

Im mounting rclone via nssm - so its a service as local system, this gives everyone on the system (users) access to the mount. this seams to work, but im getting permissions issue

as another user i can access files, add new files. but i cannot save changes to a file?
(yet i can copy and paste a new file over the top)

any idea how to fix this?

When you hit the question template, you can help by filling out all the required fields on that.

You need to add --allow-other to your mount command.

i have had a look and --allow-other is linux only - seams to have no effect in windows

What rclone version are you running?
What is the mount command you are using?

Also, look at:

https://rclone.org/commands/rclone_mount/#windows-caveats

PS C:\rclone> .\rclone version
rclone v1.50.2

  • os/arch: windows/amd64
  • go version: go1.13.4

command - via nssm:

nssm install rclone-mount-s3 C:\rclone\rclone.exe mount "s3:removed/ k: --allow-other --config C:\rclone\rclone.cfg"

hello,

you need to read this
https://rclone.org/commands/rclone_mount/#file-caching
and add flag
--vfs-cache-mode=writes
and test again.

make sure to restart the nssm service.

you need to do is update your version of rclone.

and make sure you are using the latest version of winfsp
https://github.com/billziss-gh/winfsp/releases/tag/v1.6.

updated nssm:

mount s3:removed/ s: --vfs-cache-mode=writes --allow-other --config C:\rclone\rclone.cfg
updated rclone:
PS C:\rclone> ./rclone version
rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

installed winfsp as per that link ver 1.6.20027

and still have the same issue. unable to save changes to a existing file

ok, we got the basics out of the way.

what is the file extension?
what is the size of the files you want to edit?
what program are you using to edit the files?

did you read the link i provided?

have you tried https://rclone.org/commands/rclone_mount/#vfs-cache-mode-full

im trying this with a simple text file

text.txt, editing via windows notepad
all im doing is adding another line.
when i click save i get the saveas dialogue come up.
when i try to overwrite i get "you do not have permission to open this file. see file owner"

yes i have read the link

this is to do with how localsystem is giving permission to other users, for some reason write is missing (writes are done via special permissions, and i guess the ability to overwrite is missing?)

if i run this in a local user prompt, it works fine.

if anyone else encounters this problem, where a user doesnt get execute permission, when using system account then add this to params:

-o --UserName=nameofaccount

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.