Why is downloading with Rclone so incredible fast?

Hello there,
I was asking myself many times why I can almost use 100% of my GBit connection when downloading files with rclone (single connection is enough) but when I download with wget, aria2, ftp, http or some other speedtests I'm getting capped at 400-600MBit real quick, does not matter how many parallel connection I use. I also don't think that I'm getting capped by my CPU (3740QM @3,5GHz) Rclone is not using more than 10-20% CPU load, wget for example is not using much more but I know that it can only use a single core. But I'm also getting speed capped by other protocols and tools.
I tried 4 different network drivers for the Intel 82579LM, tried to work around with the driver settings (setting caching higher and allow higher network latency) but I only could gain around 50MBit more speed meanwhile the dpc latency when up like crazy.
I also bought a USB 3.0 USB GBit interface (realtek) but nothing changed in speed. People on the net claim that they can achieve GBit speeds on a Raspberry Pi 4, my laptop should be much faster.
Someone has any ideas or explanation why Rclone is so good?

hi,
not sure what you are asking?

that the pi4 is slow?

No I was asking why the download speed is much faster using rclone compared to wget or some other protocols and tools.

You are not comparing the same things...

Wget / FTP / etc. are all single threaded clients.

Rclone by default starts 4 threads in a larger copy

Yes I know that. Thats why I said that even with one thread rclone achieves GBit speed.
Of course I also tested with more threads via wget, http, ftp, also aria2 using up to 8 threads. (peering is not limiting, I can achieve GBit on my gaming machine from every sever I've tested)
The question is, why is rclone so incredible fast?

Oh and just to make sure I also run some iperf tests with up to 40 parallel threads with same slow speeds up to 600MBit. So why is rclone so incredible fast?

Short answer: because rclone rocks! :slight_smile:

Slightly longer answer: because both rclone and whatever remote you are using rock! :slight_smile:

Longer answer: be sure you are comparing rclone and aria2 with suitable 'remotes'; for example, when multithread-downloading from an optimized HTTPS 'remote', I know for a fact that aria2 can blow rclone with a Google Drive remote right out of the water...

Cheers,
-- Durval.