Why am I getting a log message every minute, not every 10 minutes?

What is the problem you are having with rclone?

I don't understand why I'm getting a log message every minute.

My cron job looks like this:
*/10 * * * * . /home/chris/.profile; /xxx/sysadmin/linux_backup_mydocuments.sh >> /xxx/loggingfile.log 2>&1

(NB xxx is not the real path...)

What is your rclone version (output from rclone version)

rclone v1.49.4

  • os/arch: linux/amd64
  • go version: go1.13.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux Mint 18.3 64x

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

(in the above .sh file which is run every 10 minutes)

rclone -L sync "/media/mike/W10 D drive/My Documents/" remote:MyDocuments_M17A_from_Linux -v

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

I changed the above reclone from "-v" to "-vv". This resulted in vast output the next time rclone ran. Not sure which parts are significant:

2020/01/14 08:30:01 DEBUG : rclone: Version "v1.49.4" starting with parameters ["rclone" "-L" "sync" "/media/mike/W10 D drive/My Documents/" "remote:MyDocuments_M17A_from_Linux" "-vv"]
2020/01/14 08:30:01 DEBUG : Using config file from "/home/chris/.config/rclone/rclone.conf"
2020/01/14 08:30:02 DEBUG : accounts/readme.txt: Size and modification time the same (differ by 0s, within tolerance 1ms)
2020/01/14 08:30:02 DEBUG : accounts/readme.txt: Unchanged skipping
... [endless similar stuff]
(several messages like this at the end:)
2020/01/14 08:30:11 DEBUG : pacer: low level retry 1/10 (error googleapi: Error 403: User Rate Limit Exceeded. Rate of requests for user exceed configured project quota. You may consider re-evaluating expected per-user traffic to the API and adjust project quota limits accordingly. You may monitor aggregate quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/drive.googleapis.com/quotas?project=202264815644, userRateLimitExceeded)
2020/01/14 08:30:11 DEBUG : pacer: Rate limited, increasing sleep to 1.577801501s

-v will give you a stats log every minute by default - is that what you mean?

You can change the frequency of that with the --stats flag. Just set it very large if you don't want them.

Thanks... my mistake, I assumed -v was just a "verbose" option.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.