What's the best practice to mount rclone crypt for video streaming on Ubuntu?

What is the problem you are having with rclone?

What's the best practice to mount an rclone crypt remote (Google drive) for streaming videos?

My stored video files are 700 - 5300 Megabytes in size. And the video always gets downloaded in full before it starts. I tried all kinds of variations with different chunk sizes and flags - same results.

Question 1:
I don't want to guess here, but rather am interested in a best practice or recommended command and flags usage for video streaming from a crypt remote on Google drive.

Question 2:
I originally wanted to serve the directories from a server using rclone serve SFTP (or WebDAV) and then mount the SFTP (or WebDAV) on the client-machine.

Do you recommend this or should I just mount the Google drive directories directly on the client-machine using rclone mount?

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gdrive.crypt: /mnt/gdrive --fast-list --allow-other 

For best experience you have to add cache - then files do not have to be downloaded in full.

On Linux the best way is to create systemd service. Here you are very good example - you can tweak it to your needs:

It says Dropbox but pretty much the same you can use for Google.

I want to watch the video files in my collection (each ~ 700 MB), but dont want to wait till it all downloads before it starts.

Currently streaming does not work. The video just doesnt show, until its all downloaded.

I use:

rclone serve http gdrive.crypt:/ --config /home/mv337/.config/rclone/rclone.conf --addr :8080 --fast-list --dir-cache-time 9999h --cache-dir=/opt/rclone-cache --vfs-cache-mode full --vfs-cache-max-size 30G

you are mixing things.

For what you described use mount not serve


rclone mount gdrive.crypt: /mnt/gdrive --config /home/mv337/.config/rclone/rclone.conf --fast-list --allow-other --dir-cache-time 9999h --cache-dir=/opt/rclone-cache --vfs-cache-mode full --vfs-cache-max-size 30G

and you will be able to watch films without any issue.

still does not work - it keeps loading but nothing happens

post results of:

rclone version

post content of your rclone.config file - remove all passwords etc.


rclone mount gdrive.crypt: /mnt/gdrive --config /home/mv337/.config/rclone/rclone.conf --fast-list --allow-other --dir-cache-time 9999h --cache-dir=/opt/rclone-cache --vfs-cache-mode full --vfs-cache-max-size 30G --log-level DEBUG --log-file ~/rclone.log

try to play something, unmount and upload created rclone.log file here

rclone v1.63.0

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-76-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.5
  • go/linking: static
  • go/tags: none


type = drive
scope = drive
token = {"access_token":"XXXXXXXXXXXXXXXXX","token_type":"Bearer","refresh_token":1XXXXXXXXXXXXXXXXX","expiry":"XXXXXXXXXXXXXXXXX"}
root_folder_id = 

type = crypt
remote = gdrive:/

rclone.log (437.0 KB)

1 Like

It is not good idea to use crypt on gdrive root

create crypt folder on gdrive - move all your encrypted content there and change gdrive.crypt to:

type = crypt
remote = gdrive:crypt

@asdffdsa if you have a moment could you please look at this? I am off for now.

The issue was Ubuntu 22.04. I reinstalled the OS and now it works.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.