What is wrong with this filter?

Just reactivated my MEGA account and trying to setup a sync. Here's my current filter:

# rclone filter for /home

+ Desktop/**
+ Documents/**
+ Development/**
+ Downloads/**
+ Pictures/**
+ Saved Games/**

- .cache/**
- .config/Code/**
- .config/FreeTube/**
- .config/obsidian/**
- .config/vivaldi/**
+ .config/**

+ .gnupg/**
- .local/share/Steam/**
- .local/state
+ .local/**
- TripleA/**
- Videos/**

# global catch-alls
- *
- .*

Running the command

rclone -v sync $HOME mega:/ --filter-from=$HOME/.config/rclone/rclone_home.conf --dry-run

the exclusions that are not countered anywhere (like TripleA and Videos) are working, but the others are not. I've tried reversing the order (putting the exclusions after the inclusions), with no success. I've done this before with rsync successfully, so I'm not sure what I'm doing wrong here.

Could you give an example what is not working? What is the path you intend to filter and it is not?

All of the exclusions that are following an inclusion: - .config/vivaldi/** (after + .config/**), - .local/share/Steam/** (after + .local/**), for example. As I mentioned, I've tried reversing the order to no avail. For now, I'm using an --exclude-if-present switch to block these directories from syncing.

Can you give me an example of the path which is not excluded?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.