What does --allow-other do

not clear what the flag --allow-other does,
the documention states Allow access to other users

but what kind of users, windows users, rclone users or what?

if i run the rclone mount on windows as system user do i need to use the flag?

in testing, i have run rclone mount as system user, with and without that flag and i see no difference in behaviour.

A technical-level clarification on this would be nice.

I think it's primarily for if you run rclone under a regular user-account, for other regular user-accounts to access it. But it would be neat to know what it actually does under the hood.

It allows other users other than the one running the process to access the fuse mount.

If you don't use allow other, only the user running the rclone process has access.

so based on my testing on windows, when running rclone mount as system user, there is no need for the flag.

I'm not 100% sure the flag does anything on Windows - It is used on Linux/macOS normally.

this is exciting, a rclone mystery and a windows vs. linux debate.

@asdffdsa If you could run under a normal user - and access via another normal user, that would probably answer this question once and for all - because if it's not even needed for that then the flag wouldn't have any purpose anyway.

I'm really uncertain now because I've been assuming this was required for a long time. I think I've been just using it from the start without verifying that.

It's not a mystery. The fuse options for WinFSP are here:

Allow other isn't an option on it as I shared.

well, it was a genuine mystery for a few minutes, and i really enjoyed it.

well, @Animosity022 seems to have killed my innocent little mystery..
i was falling in love with that mystery and now, so quickly, so suddenly, it has been taken from us.

but your suggestion is a good one and i will try to test it.

my little mystery did not die in vain, for we have learned something that will endure thru time.
goodbye little mystery, we will not forget you!

it seems that the flag does nothing on windows.
to share the mount on windows, we must run rclone as system user.

for testing i used the following script, once with the flag and once without the flag.
i ran the script using task scheduler as a standard user named standarduser.
in both runs, i, as administrator user was NOT able to access x:

whoami > logfile.txt
set flags=--allow-other --dir-cache-time=72h --drive-chunk-size=64M --vfs-read-chunk-size=32M --vfs-read-chunk-size-limit=off --vfs-cache-mode=writes --cache-dir=c:\dest --log-level=DEBUG
set mountsource=wasabiwest01:thetestfolder
set mountdrive=x:
set logfile=--log-file=logfile.txt
rclone.exe mount %mountsource% %mountdrive% %flags% %logfile%

and here is once of the logs with the flag

2019/10/15 14:42:15 DEBUG : rclone: Version "v1.49.3" starting with parameters ["rclone.exe" "mount" "wasabiwest01:thetestfolder" "x:" "--allow-other" "--dir-cache-time=72h" "--drive-chunk-size=64M" "--vfs-read-chunk-size=32M" "--vfs-read-chunk-size-limit=off" "--vfs-cache-mode=writes" "--cache-dir=c:\dest" "--log-level=DEBUG" "--log-file=logfile.txt"]
2019/10/15 14:42:15 DEBUG : Using RCLONE_CONFIG_PASS password.
2019/10/15 14:42:15 DEBUG : Using config file from "C:\data\rclone\scripts\rclone.conf"
2019/10/15 14:42:15 DEBUG : S3 bucket thetestfolder: Mounting on "x:"
2019/10/15 14:42:15 INFO : S3 bucket thetestfolder: poll-interval is not supported by this remote
2019/10/15 14:42:15 DEBUG : vfs cache root is "c:\dest\vfs\wasabiwest01\thetestfolder"
2019/10/15 14:42:15 DEBUG : Adding path "vfs/forget" to remote control registry
2019/10/15 14:42:15 DEBUG : Adding path "vfs/refresh" to remote control registry
2019/10/15 14:42:15 DEBUG : Adding path "vfs/poll-interval" to remote control registry
2019/10/15 14:42:15 DEBUG : S3 bucket thetestfolder: Mounting with options: ["-o" "fsname=wasabiwest01:thetestfolder" "-o" "subtype=rclone" "-o" "max_readahead=131072" "-o" "attr_timeout=1" "-o" "atomic_o_trunc" "-o" "uid=-1" "-o" "gid=-1" "--FileSystemName=rclone" "-o" "volname=wasabiwest01 thetestfolder" "-o" "allow_other"]

1 Like

Haha, same here. I do remember needing it at one point, though. Will try without the flag and see what happens.

Works fine without the flag!

Would someone like to send a pull request patching the help here to say (not Windows) at the end?

There are probably other commands which are ineffectual on Windows too.

i am having a hard time creating the pull request.
it seems to be arbitrarily complicated and not user friendly.

from the page with the source code, i should be able to click a button and type my pull request.

instead i have to goto another page to initiate the request but then it seems to stupid to know which source code i want to do the pull request on and i cannot figure out how to tell it.

even more annoying is that when i click on
there is no option for a pull request.

there are a bunch of changes i would like to make.

You can read this as a starting guide:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.