WebGUI works once and only once!


I've seen others here mention issues but never a real resolution. I have found the web GUI working properly to be extremely non-deterministic. I cannot get it to consistently start and not keep asking for a password. I'll include everything below as applicable, but the gist if it is, you run the GUI and it sometimes works and sometimes it prompts for a passowrd. So you set it with a password and it still does not work.

What is the problem you are having with rclone?

Starting the webGUI is unreliable at best. Generally, it works once and then doesn't work again. Even with a specified username and password.

What is your rclone version (output from rclone version)

rclone v1.54.0
- os/arch: darwin/amd64
- go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS 10.15.7

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)


$ rclone -vv rcd --rc-web-gui

But also

$ rclone -vv rcd --rc-web-gui --rc-web-gui-force-update

In both of those cases, it brings up the WebGUI but asks for a password. FWIW, there is a token in the URL like http://localhost:5572/?login_token=Z3VpOlRxcFBOTU44QXBVd09yVldkV3dRa1E%3D#/dashboard

So I also tried specifying username and pass

$ rclone -vv rcd  --rc-web-gui --rc-user gui --rc-pass pass 

And I get prompted again. It does not accept those credentials either

Like I said, what is frustrating is the this occasionally works. I just cannot seem to figure out what combination of magic I need to provide to get it to launch every time! Basically, the first time it works and then stops.

I've also tried restarting my browser and/or doing it in a Private Window. No luck.

The rclone config contents with secrets removed.


A log from the command with the -vv flag

2021/02/02 13:50:09 DEBUG : rclone: Version "v1.54.0" starting with parameters ["rclone" "-vv" "rcd" "--rc-web-gui"]
2021/02/02 13:50:09 DEBUG : Current tag: v2.0.3, Release tag: v2.0.3
2021/02/02 13:50:09 NOTICE: Web GUI exists. Update skipped.
2021/02/02 13:50:09 INFO  : No username specified. Using default username: gui
2021/02/02 13:50:09 INFO  : No password specified. Using random password: zX7WllimTBhe1mEmkfAO9A
2021/02/02 13:50:09 NOTICE: Serving Web GUI
2021/02/02 13:50:09 INFO  : Using --user gui --pass XXXX as authenticated user
2021/02/02 13:50:09 NOTICE: Serving remote control on http://localhost:5572/
2021/02/02 13:50:09 DEBUG : login_token "Z3VpOnpYN1dsbGltVEJoZTFtRW1rZkFPOUE="
2021/02/02 13:50:10 INFO  : /core/version: Unauthorized request from gui

I also tried

$ rclone  -vv rcd --rc-web-gui  --rc-no-auth

and it still didn't work. Even in a Private Window. Kept asking for credentials

You want to clear your cache on your browser.

You have a cookie/something from a previous run.

I can recreate it with an old cookie every time.

Wouldn't using Private mode negate that as the cause?

It validates what the problem is and it works in a private browser was what I was trying to show as I didn't feel like clearing my cookies or hunting down the offending one in the cache.

If you are using the same loopback, you'd a cookie like this.

You can remove it / restart browser and you can log in.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.