Webgui Login Password

Hi All

first time trying rclone on linux mint 20, went to try the web interface using "rclone rcd --rc-web-gui", added my dropbox & gdrive to the configs, didnt setup mount points, as re-started PC. Now when I try to log into the web interface, it asks for username/pass? but i dont remember entering one? tried my login credentials? tried admin/admin admin/pass admin/password root/mypassword to no avail? was just wondering if someone could point me in the right direction?

cheers Phil

hello and welcome to the forum,

by default, rc requires a username and password

https://rclone.org/rc/#rc-no-auth

Hi Jojothehumanmonkey,

yep, but i dont remember entering any passwords on my install apart from the passwords for my accounts.

just installed rclone on a virtual machine, it said that the latest download was newer than the one in software channel, but i installed the website version, ran the installer, and then ran the "rclone rcd --rc-web-gui" from terminal, it said im going to use gui as the login, but never asked for a password?

cheers
Phil

as per the documents,
By default rclone will require authorization to have been set up on the rc interface

you need to set a username and password using --rc-user and --rc-pass
if you do not want to use username and password then use --rc-no-auth

also, when you posted you were asked for information, can you please supply it

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Apologies, i thought mentioning being on linux mint 20 might have been sufficient.

Linux Mint 20 Cinnamon (4.6.7) 64bit, Kernel 5.4.0-42-generic,

rclone-v1.52.3-linux-amd64.deb, confirmed with looking in the bottom left hand corner of the web interface page.

rclone.conf
[Dropbox1]
type = dropbox
token = CUT OUT

[skeggygmail]
type = drive
token = CUT OUT

rclone rcd --rc-web-gui -vv
2020/08/28 15:43:25 DEBUG : rclone: Version "v1.52.3" starting with parameters ["rclone" "rcd" "--rc-web-gui" "-vv"]
2020/08/28 15:43:25 NOTICE: Web GUI exists. Update skipped.
2020/08/28 15:43:25 INFO : No username specified. Using default username: gui
2020/08/28 15:43:25 INFO : No password specified. Using random password: EZY2C_IaeUa1mRKjFhCG9w
2020/08/28 15:43:25 NOTICE: Serving Web GUI
2020/08/28 15:43:25 INFO : Using --user gui --pass XXXX as authenticated user
2020/08/28 15:43:25 NOTICE: Serving remote control on http://127.0.0.1:5572/
2020/08/28 15:43:25 DEBUG : login_token "Z3VpOkVaWTJDX0lhZVVhMW1SS2pGaENHOXc="
2020/08/28 15:43:39 INFO : /core/version: 127.0.0.1:49318: Unauthorized request from gui
2020/08/28 15:43:39 INFO : /core/stats: 127.0.0.1:49328: Unauthorized request from gui

I will try again when i get home, ill set up a fresh VM, and check for more messages. the reason i didnt enter a password was because i was never asked for one upon running the "rclone rcd --rc-web-gui", and on the webpage https://rclone.org/gui/, the mention of passwords are further down the page on the advanced section.

the password is in the log file
Using random password: EZY2C_IaeUa1mRKjFhCG9w

and keep in mind that the gui interface is considered Experimental so i would not trust it.

depending on what you need to do; if you want a gui that is stable, i would recommened

oki, ill have a go later if i get chance, and try the password tomorrow at work, ill install a fresh VM later if i get chance :slight_smile:
thanks for your help so far

let us know what happens

Hi there,
I installed a fresh VM of Linux mint 20, updated the installation, downloaded 1.52.3 Deb installer from website, installed the software.

Ran "rclone config", which then asked to set password, which i did, and then added dropbox via command line. It said it was successfull in adding dropbox to the config, i didnt set a path to the local site, just got the key.

logged out, ran "rclone rcd --rc-web-gui", it didnt ask me for any password, just said successful logged in. i logged out and then tried to log back in with "gui & setpassword" from config earlier, it wouldnt let me log in. I ran "rclone rcd --rc-web-gui -vv" to show me the random password, what you mentioned last night, and it didnt work with gui as the username, although running the same command again, showed me a different password, i guess being random?

i then re-ran "rclone config" , it asked me for password, which again i entered, and it logged me in, would un-encrypting the password help?

I forgot to make a copy of the VM or timeshift it as customers were coming through door.. ill re-do another, later and make a backup as needed, and try another configuration from scratch.

cheers
Phil

that password is used to encrypt the config file, nothing to do with rcd command.

no need to redo the config file, as it has nothing to do with the rcd command.

keep in mind that the gui is experimental, might be a bug

if you need a gui, then https://kapitainsky.github.io/RcloneBrowser/

I'm having this same issue and wanted to know if you were able to get this sorted. If not I'll just go back to using rclone browser.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.