Webdav deletes are not reflected

What is the problem you are having with rclone?

I am using to serve a webdav backend with direct local files (without a preset backend). I can see the files in the browser using the I delete a file from the folder but the resulting change is not reflected in the browser. So the deleted file still shows up in the browswer, even though it is deleted from the file system.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1
- os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
- os/kernel: 10.0.19045.3803 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.20.6
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

I am not using any cloud storage or a backend

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe serve webdav --addr "C:\SYNC"

It takes up to 5 min for changes to be propagated. So wait some time and then refresh your browser. The file should be gone. You can control it by adjusting VFS directory cache flag:

--dir-cache-time duration           Time to cache directory entries for (default 5m0s)`
1 Like

Thanks for the tip (set it up for 5s for now). I guess then my issue is more complicated than that :frowning:

I use this Obsidian plugin to sync ( i just set it up couple hours ago and I have been testing it), this plugin puts those deleted files back:( Although I see that the deleted files are now removed from the listing inside the browser so that is an improvement for my case.

Would there be another option that makes this plugin to think that the files were not or should not be deleted?

This has nothing to do with rclone IMO. Ask this plugin community for help.

1 Like

Thanks, --dir-cache-time was definitely my main my issue. That is now resolved.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.