Web UI connection issues on a hosted Rclone

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

I need to sync files from S3 bucket to other cloud providers on an ongoing, automated basis. Ive installed rclone on a (headless, Ubuntu) EC2 instance. The CLI version runs OK, but cant connect to the Web UI. I've tried running the following based on this video: Ten Minute Tutorial for Research: Rclone Web GUI on AWS | AWS Public Sector - YouTube

  1. rclone rcd --rc-web-gui --rc-addr :5572 --rc-user myuser --rc-pass mypass

Which gives me:
2023/05/12 21:43:02 NOTICE: Web GUI exists. Update skipped.
2023/05/12 21:43:02 NOTICE: Serving Web GUI
2023/05/12 21:43:02 NOTICE: Serving remote control on http://[::]:5572/
2023/05/12 21:43:02 ERROR : Failed to open Web GUI in browser: exec: "xdg-open": executable file not found in $PATH. Manually access it at: hxxp://myuser:mypass@[::]:5572/?login_token=SOMETOKEN

However, when visiting http://myEC2ipaddress:5572/ I get a timeout (site cant be reached).

2. Running Web UI on a localhost (Windows 10) and trying to connect to my EC2
This also gives me a timeout after a few seconds.

I have access to two EC2 servers and have tried the above with both, yielding identical results.

Im obviously on the wrong track somewhere.... Any input would be appreciated!

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 20.04 (64 bit)
  • os/kernel: 5.15.0-1035-aws (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-web-gui --rc-addr :5572 --rc-user myuser --rc-pass mypass

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

This is the right thing to be doing and what you've done is correct as far as I can see.

A timeout probably indicates a firewall in the way.

Probably the same reason. Your EC2 instance is behind a firewall which isn't allowing port 5572 connections through.

Hey Nick,

Thank you for the response. Its nice to know I was on the right track.. I also suspected it may be a firewall, so thank you for pointing me in the right direction.

Thank you, kind Sir for developing, sharing and supporting your work with the community!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.