Web Gui Showing As Basic File Browser

What is the problem you are having with rclone?

I'm able to access the web gui, but it appears to be only an interactive file browser? It doesnt look anything like the images I find when I search for it. Is something missing from my config or setup?

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)


Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

version: "3.1"
    image: rclone/rclone:latest
    container_name: rclone
    restart: unless-stopped
    command: rcd --rc-web-gui-no-open-browser -vv --rc-serve --rc-web-gui-force-update --rc-addr :5572
      - 5572:5572
      - PUID=1000
      - PGID=1000
      #- VERSION=docker
      - /srv/dev-disk-by-label-codex/docker/configs/rclone:/config/rclone
      - /srv/dev-disk-by-label-codex/docker/logs/rclone:/logs
      - /srv/dev-disk-by-label-codex/docker/data/rclone:/data
      - "traefik.enable=true"
      - "traefik.http.routers.rclone.rule=Host(`rclone.example.com`)"
      - "traefik.http.routers.rclone.entrypoints=websecure"
      - "traefik.http.routers.rclone.tls=true"
      # Uncomment to fetch Let's Encrypt certificates.
      # Make sure you set up DNS records and they point to your IP.
      - "traefik.http.routers.rclone.tls.certresolver=letsencrypt"

      name: traefik_default

The rclone config contents with secrets removed.

type = pcloud
hostname = eapi.pcloud.com
token = {"access_token":"myprivatetoken","token_type":"bearer","expiry":"0001-01-01T00:00:00Z"}

A log from the command with the -vv flag

2021/04/10 07:01:26 DEBUG : Using config file from "/config/rclone/rclone.conf",
2021/04/10 07:01:26 DEBUG : rclone: Version "v1.55.0" starting with parameters ["rclone" "rcd" "--rc-web-gui-no-open-browser" "-vv" "--rc-serve" "--rc-web-gui-force-update" "--rc-addr" ":5572"],
2021/04/10 07:01:26 NOTICE: Serving remote control on http://[::]:5572/,

hello and welcome to the forum,

"If you wish to check for updates then you can add --rc-web-gui-update to the command line.
If you find your GUI broken, you may force it to update by add --rc-web-gui-force-update"

have you tried RcloneBrowser | Simple cross platform GUI for rclone. Supports macOS, GNU/Linux, BSD family and Windows.

Hi, thanks for the reply.

I have tried the gui-update and force-update flags, but it doesnt change anything. Tried deleting the image and rebuilding the container a few times with no luck either.

I havent tried that browser, but I might give it a shot.

Think I figured out what I was missing.

Looks like I had to add the flag --rc-web-gui and everything started working!
Guess I figured the -no-open-broswer did the same thing as the base command but suppressed the browser. Also removed the --rc-serve since I didnt need that anymore.

command: rcd --rc-web-gui-no-open-browser --rc-web-gui -vv --rc-addr :5572 --rc-user admin --rc-pass pass

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.