Web Gui ‘Not Found’

What is the problem you are having with rclone?

Getting page not found when accessing rclone webgui

Run the command 'rclone version' and share the full output of the command.

rclone v1.55.1-DEV

  • os/type: linux
  • os/arch: amd64
  • go/version: go1.15.5
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-web-gui-no-open-browser --rc-addr=:5572 --rc-user=user --rc-pass=pass --rc-web-gui-update -vvv

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

2022/07/01 15:15:16 DEBUG : Using config file from "/home/nbcsg/.config/rclone/rclone.conf"
2022/07/01 15:15:16 DEBUG : rclone: Version "v1.55.1-DEV" starting with parameters ["rclone" "rcd" "--rc-web-gui-no-open-browser" "--rc-addr=:5572" "--rc-user=user" "--rc-pass=pass" "--rc-web-gui-update" "-vvv"]
2022/07/01 15:15:16 INFO  : Using --user user --pass XXXX as authenticated user
2022/07/01 15:15:16 NOTICE: Serving remote control on http://[::]:5572/

I read multiple support tickets with similar issue but non worked for me. Any help is highly appreciated

I think you are mixing two things.

If you want a web gui.

You'd use:

rclone rcd --rc-web-gui

If you want a rcd only, no web gui, you'd use what you had.

What are you trying to do? Get a webGUI?

Yes I tried that and it didn't return a GUI until I specified a path
Initially I run the following
rclone rcd --rc-web-gui-no-open-browser --rc-addr=:5572 --rc-user=user --rc-pass=pass --rc-web-gui-update -vvv
which returned a NOT Found page.
I added the flag --rc-files /path/to/directory and returned a page

As I noted above that only runs a remote control daemon and no web gui.

For a web gui, you need.

Not what you are using as that's not the proper way.

Isn't that what I'm running in the command "rclone rcd --rc-web-gui-no-open-browser"
The documentation says -


Set this flag to disable opening browser automatically when using web-gui.

No, that's a flag to disable the automatic pop up for the web browser. The key word is there "when using the web-gui". You have to run the web-gui first to use a flag for it if that makes sense.

If you run the command I shared, it'll pop up a browser.

if you don't want to do that, you add that flag and a browser won't automatically open up. It's useful for headless machines like a server or maybe a remote desktop you don't want to auto pop open a browser.

Docs are here:

GUI (rclone.org)

Ok that make sense - I only used the --rc-web-gui-no-open-browser thinking it achieves the same behavior except with no browser. I think the description should be adjusted it. Look like many people are failing into the same mistake

Best part of open source is you have the ability to adjust it. Feel free to make any wording adjustments you’d find helpful.