VPS rclone plex server


i rent a vps on debian 9 and installed rclone and plex server.

plex is running
rclone is running

the last problem i have is that i don't arrive to mount the folder to plex be able to point it

commands are working fine :
rclone lsd gdrive_media_vfs:
rclone ls gdrive_media_vfs:

command not working : rclone mount --allow-other gdrive_media_vfs: /var/tmp/gdrive_media_vfs

error message : 2019/07/08 08:45:59 Fatal error: Can not open: /var/tmp/gdrive_media_vfs: open /var/tmp/gdrive_media_vfs: no such file or directory

i tried this too: rclone mount gdrive_media_vfs:path/to/files /path/to/local/mount

mountcheck is working well

i am a noob with debian and vps, what should i do?


That's an odd spot to mount it.

In Linux, it's look for a directory that is empty to mount it to.

I use /GD for my mount so you'd have to:

mkdir /GD (probably as root as I have it my root location)
or you can do

mkdir /home//GD
and mount it to /home//GD

1 Like

hello thanks, can you write me the command i am not sure to understand :slight_smile:

That is the command I wrote:

Last login: Mon Jul  8 07:48:35 2019 from
[felix@gemini ~]$ pwd
[felix@gemini ~]$ mkdir GD
[felix@gemini ~]$ rclone mount gcrypt: /home/felix/GD

and that would mount it to /home/felix/GD

ok i did this mkdir GD (i see it in plex empty
and did this : rclone mount gdrive_media_vfs: /home/GD

need i restart plex server?

when i do this now rclone mount gdrive_media_vfs: /home/GD
i have this message : 2019/07/08 09:13:04 Fatal error: Directory is not empty: /home/GD If you want to mount it anyway use: --allow-non-empty option
because i don't see anything in GD

ls -al /home/GD

It has something in it.

i did it once when you told me it was empty and worked

but now this is not empty but i see nothing in PMS

but no file in there

i did again a mount check i have this

What's the mount command you are using? You need to use --allow-other

i use rclone mount gdrive_media_vfs: /home/GD

i just tried ~# rclone mount gdrive_media_vfs: /home/GD --allow-other
2019/07/08 09:31:22 Fatal error: Directory is not empty: /home/GD If you want to mount it anyway use: --allow-non-empty option

i tried rclone mount gdrive_media_vfs: /home/GD --allow-non-empty no message error but nothing in plex

You probably already have a mount running.

You really never ever want to use --allow-non-empty as that allows for over mounting.

Make sure no rclone is running and run the command.

how to make sure no rclone is running?

Use the ps command and see if any other processes are going:

[felix@gemini ~]$ ps -ef | grep rclone
felix      781     1  0 09:03 ?        00:00:19 /usr/bin/rclone mount gcrypt: /GD --allow-other --buffer-size 1G --dir-cache-time 96h --log-level INFO --log-file /opt/rclone/logs/rclone.log --timeout 1h --umask 002 --user-agent animosityapp --rc
felix     7105  2644  0 09:49 pts/0    00:00:00 grep rclone

and if they are:

kill 781

781 is the process ID or PID showing above.

i reinstalled everything on a new vps and i have now this problem for the command:

rclone mount gdrive_media_vfs: /home/GD --allow-other2019/07/08

11:19:05 mount helper error: fusermount: fuse device not found, try 'modprobe fuse' first

i uninstall fuse reinstall but not working

i did this : root@srv0XXX:~# ls -l /dev/fuse
crwxrwxrwx 1 root root 10, 229 juil. 8 11:13 /dev/fuse

i don't understand

As root, follow what it says and type:

modprobe fuse

libkmod: ERROR ../libkmod/libkmod.c:505 kmod_lookup_alias_from_builtin_file: could not open builtin file '/lib/modules/2.6.32-042stab136.1/modules.builtin.bin'
FATAL: Module fuse not found.

That means your OS is messed up and/or fuse is not installed properly.

can it be the hoster the problem? i activate the fuse option in admin panel

No idea, Work with your VPS provider.

1 Like


i solved this by :
1 - changing vps (the other one didn't support fuse)
2- apply your command mkdir
3- and choose ubuntu and not debian 9 or centos

everything work fine now, i configured it in 5 minutes with this (5 hours lost before)

thanks a lot for your help, hope this update will help someone one day

here the command i used (without rclone part creation drive)

1- connect
ssh root@xxxxxx

2- Plex installation

i used this : https://www.lavavps.lt/login/knowledgebase.php?action=displayarticle&id=107

apt-get update

apt-get install wget

wget https://downloads.plex.tv/plex-media-server-new/

dpkg -i plexmediaserver_*.deb

apt-get install curl apt-transport-https

echo deb https://downloads.plex.tv/repo/deb ./public main | tee /etc/apt/sources.list.d/plexmediaserver.list

curl https://downloads.plex.tv/plex-keys/PlexSign.key | apt-key add -

apt-get update


3- installer unzip
apt-get install zip

4- rclone installation


curl https://rclone.org/install.sh | sudo bash -s beta

5_ installer fuse

Enable fuse in hosting panel

sudo apt-get update
sudo apt-get install fuse

6- monter rclone

touch mountcheck

rclone copy mountcheck gdrive_media_vfs: -vv --no-traverse

mkdir /home//GD

rclone lsd gdrive_media_vfs:
rclone ls gdrive_media_vfs:
rclone mount gdrive_media_vfs: /home/GD --allow-other