Video playback gets interrupted during high network activity

On jellyfin, not plex or emby, video playback gets interrupted during high network activity. It seems there is no buffer for the video playback or something.
What exactly is responsibly for the buffering in my mount?(maybe i can set a better buffer for playback)

Environment=RCLONE_CONFIG=/opt/rclone/rclone.conf
KillMode=none
RestartSec=5
ExecStart=/usr/bin/rclone mount drive: /mnt/drive \
--allow-other \
--buffer-size 256M \
--dir-cache-time 8760h \
--poll-interval 15s \
--log-level INFO \
--log-file /opt/rclone/logs/rclone.log \
--timeout 1h \
--umask 002 \
--user-agent rclone \
--rc \
--rc-addr 127.0.0.1:5572

It depends as to what Jellyfin is doing as opposed to Emby or Plex.

A file that's open and is read sequentially is impacted by

as it reads in memory till it hits the buffer size. Once the file is closed, the buffer is dropped and the process repeats.

So it depends if it's reading it sequentially, transcoding or whatever it is doing.

You'd want to post a rclone debug log of one working and one not working and compare the two to see what's going on.

i never transcode, but this happens for when others transcode my files and when i direct stream.

the video was media/movies/Bad Girl (2016)/Bad Girl (2016).mkv

ExecStart=/usr/bin/rclone mount drive: /mnt/drive \
--allow-other \
--buffer-size 256M \
--dir-cache-time 96h \
--poll-interval 15s \
--log-level DEBUG \
--log-file /opt/rclone/logs/rclone.log \
--timeout 1h \
--umask 002 \
--user-agent rclone \
--rc \
--rc-addr 127.0.0.1:5572

and here is another crash after adding vfs args

--vfs-cache-mode writes \
--vfs-read-chunk-size 128M \
--vfs-read-chunk-size-limit off \

Looks like you've started activated Google's rate limiter

2020/02/03 09:25:21 DEBUG : pacer: Rate limited, increasing sleep to 4.138610895s
2020/02/03 09:25:21 DEBUG : pacer: low level retry 2/10 (error googleapi: Error 403: User Rate Limit Exceeded. Rate of requests for user exceed configured project quota. You may consider re-
evaluating expected per-user traffic to the API and adjust project quota limits accordingly. You may monitor aggregate quota usage and adjust limits in the API Console: https://console.devel
opers.google.com/apis/api/drive.googleapis.com/quotas?project=31857546593, userRateLimitExceeded)
2020/02/03 09:25:21 DEBUG : pacer: Rate limited, increasing sleep to 8.334505194s

You might want to add a --tpslimit to your mount?

what do you recommend i set it to?

You could try --tps-limit 3 maybe?

here is the latest crash

--allow-other \
--buffer-size 256M \
--dir-cache-time 96h \
--poll-interval 15s \
--log-level DEBUG \
--log-file /opt/rclone/logs/rclone.log \
--timeout 1h \
--umask 002 \
--user-agent rclone \
--tpslimit 5 \
--tpslimit-burst 5 \
--vfs-cache-mode writes \
--vfs-read-chunk-size 128M \
--vfs-read-chunk-size-limit off \
--rc \
--rc-addr 127.0.0.1:5572

Sounds like you have a Jellfyfin issue really. Setting the tpslimits down is just going to slow things down and I wouldn't do that.

i figured as much
thanks

i've been trying to figure it out with them for weeks.