Vfs mount Stuttering/skipping during plex playback

What is the problem you are having with rclone?

when playing a file in plex off the rclone mount all movies above 30mbps bitrate seem to skip during playback by 1 to 4 seconds every few moments. i have tried varying chunk sizes from 2M to 64M and the issue still persists. The server has a full duplex 1gbps connection so i dont believe that to be the issue. it also has 64GB of ram and a decent xeon cpu with 4c/8t.

What is your rclone version (output from rclone version)

``` rclone v1.57.0
  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-163-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none ```

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

2021/12/21 17:13:53 DEBUG : rclone: Version "v1.57.0" starting with parameters ["/usr/bin/rclone" "mount" "--config=/root/.config/rclone/rclone.conf" "--allow-other" "--allow-non-empty" "--rc" "--rc-no-auth" "--rc-addr=localhost:5576" "--drive-skip-gdocs" "--vfs-read-chunk-size=64M" "--vfs-read-chunk-size-limit=1G" "--buffer-size=16M" "--vfs-read-ahead=32M" "--poll-interval=5m" "--dir-cache-time=999h" "--timeout=10m" "--umask=002" "--read-only" "--cache-dir=/vfscache6" "--vfs-cache-mode=full" "--vfs-cache-max-size=2000G" "--vfs-cache-max-age=999h" "--transfers=32" "--log-file=/rclonelogs" "--log-level=DEBUG" "newmovies:" "/mnt/GMovies"] 

The rclone config contents with secrets removed.

type = drive
client_id = dummyid
client_secret = dummysecret
scope = drive
token = dummytoken
team_drive = Dummyname 
root_folder_id =
service_account_file = /home/sa/162.json

A log from the command with the -vv flag


Is it transcoding or direct playing?

direct playing or direct streaming, might be transcoding audio. happens with a lot of different movies.

Are you certain?

The log indicates you are playing from disk as it's all cached so either:

  1. Transcoding and something can't keep up
  2. Server is located somewhere that has latency to your player location so it can't keep up

What's the client device used for playback?

seems to be a client issue with chrome. tried on another device but the file did the same thing. Also tried the same file on local storage and it didnt happen. Very weird. I'll be testing that out over the day to make sure its fully fixed.

however can i get some advice on the flags im using?
im trying to build a scan cache using vfs but am having some trouble finding a good spot.
smaller chunk size gave me individual file cache sizes of 60ish MB while higher seemed to give me 20 to 20 MB. but not always, seems a little random.
smaller seems to give better start times on the files.
have a large library and the cache will be multiple TB if its 60MB+ per file.

want the vfs cache for the better scan times, especially with several thing scanning said files all the time and will help with keeping usage low from scans on the google side.

Basically any advice you can give me on the flags im currently using or the ones i could use for a better experience would be great.

my server is pretty active with my biga** family haha. trying to get to the a good spot sooner rather then later lol

"Scan cache" does not mean full VFS cache. Since you're already using RC, all you need is to prime the "dir" cache, which resides entirely in memory. To do that, you want to use something like this:

rclone rc vfs/refresh recursive=true --drive-pacer-burst 200 --drive-pacer-min-sleep 10ms --timeout 30m --user-agent *******

As for your mount, I would try something with fewer flags. This is what I use:

rclone mount --attr-timeout 5000h --dir-cache-time 5000h --drive-pacer-burst 200 --drive-pacer-min-sleep 10ms --no-checksum --poll-interval 0 --rc --read-only --user-agent ******* -v

Note the read-only and no disk cache...

Just saw this. Yeah, this will not work with what I proposed. I would generally advise against it anyway, but in your case an always updating full cache would probably work better.


  • is this a new media server or an already existing server that just suddently had issues.
  • could wifi be an issue?
  • i would play a media file on the server itself, direct from the rclone mount /mnt/GMovies, using vlc or media player. not using the media server,

its definitely storing files in the cache directory i specified. it seems to be working.
The idea being that i have emby, jellyfin, plex, sonarr, radarr, etc all on 1 machine so the file bits used from scans should all be used frequently and stay in the cache.
guess im just trying to make sure that my flags are doing that and the numbers make sense with the expected playback and use

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.