VFS Error Transport endpoint is not connected

What is the problem you are having with rclone?

I have installed rclone to sync onedrive, on Lubuntu 18.04.5 LTS, and all seems to be fine. I created the onedrive folder several different ways. I created the onedrive folder using GUI. and ran the command "rclone --vfs-cache-mode writes mount onedrive: ~/onedrive", I receive a "fatal error: Can not open: /home/john/onedrive: open /home/john/onedrive: transport endpoint is not connected". If I go to the file browser, I can see all of the files and folders from my onedrive, but when I try to access them, or save a new file to any remote folder, I get an error that I do not have permissions. I also tried I deleting the folder and recreating it using the mkdir command. Same error, so I tried rclone mkdir and still no luck.
I even tried setting the permissions to 777, but can not access the files.

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: linux/386
  • go version: go1.15.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Lubuntu 32 bit 18.04.5 LTS

Which cloud storage system are you using? (eg Google Drive)

Onedrive Personal

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone --vfs-cache-mode writes mount onedrive: ~/onedrive

The rclone config contents with secrets removed.

type = onedrive
token = REMOVED
drive_id = 2cdc49a9a5dadeb6
drive_type = personal

A log from the command with the -vv flag

2020/11/14 11:53:05 DEBUG : rclone: Version "v1.53.2" starting with parameters ["rclone" "-vv" "--vfs-cache-mode" "writes" "mount" "onedrive:" "/home/john/onedrive"]
2020/11/14 11:53:05 DEBUG : Creating backend with remote "onedrive:"
2020/11/14 11:53:05 DEBUG : Using config file from "/home/john/.config/rclone/rclone.conf"
2020/11/14 11:53:06 Fatal error: Can not open: /home/john/onedrive: open /home/john/onedrive: transport endpoint is not connected

Thanks for your help.

That usually means something killed the process and you have something still hitting the mount point.

You can try to fuser the mountpoint and/or just reboot. You'd wan to figure out what killed it while something was hitting the mount point as it want to stop any IO/process to the mount point.

Thanks. I rebooted and I still get the error, but as long as I don´t do anything with it, the files actually appear and I am able to read and write them. Not sure why the error is occuring, but it doesn´t seem to be affecting performance. I can´t figure out what might be hitting the mount point. Thanks for your help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.