VFS cache setting for Chia farming?

What is the problem you are having with rclone?

It uses too much cache

What is your rclone version (output from rclone version)

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount

The rclone config contents with secrets removed.

  --no-checksum \
  --use-server-modtime \
  --no-gzip-encoding \
  --no-update-modtime \
  --no-seek \
  --modify-window 2m \
  --allow-other \
  --allow-non-empty \
  --dir-cache-time 25h \
  --cache-read-retries 15 \
  --cache-db-purge \
  --timeout 30m \
  --vfs-cache-mode full \
  --vfs-read-chunk-size 2M \
  --vfs-read-chunk-size-limit 5M \
  --vfs-cache-max-size 500M
  --vfs-cache-max-age 1h \
  --attr-timeout 20s \
  --poll-interval 9m \
  --vfs-cache-poll-interval 10m

A log from the command with the -vv flag

Too large

How should I modify this config for Chia cloud farming? With the above settings it consumes all my storage

Hi dawnslayer,

I cannot answer your question, but this Backblaze article may be of interest:

1 Like

Why some of those flags? Does chia need to seek into the file? The no-seek flag may be hurting you

Thanks, what else should I remove

I don't really know Chia (other than a baseline dislike because of the havoc it has caused on the storage market, but I digress).

However, I am of the belief that the best way to approach anything with rclone is to start with the absolute simplest command and only then do you add more as needed. And as I add flags, I document why I added them. Can you tell me why you have each and every flag? Many of them aren't even for your backend! (including the confusingly named cache flags that are for the cache backend which you aren't using. Or if you are, you shouldn't be).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.