Vfs-cache-mode writes or full is recommended

Hello help guys

I set up 5 days ago and everything worked great but now when I start my server I am getting message "-vfs-cache-mode writes or full is recommended", also my streaming is poor quality now.

The command I am using is "./rclone.exe cmount realdebrid: X: --dir-cache-time 10s"

rclone version is v1.58.1-rd.2.2

I am using realdebrid

The command I am using is "..../rclone.exe cmount realdebrid: X: --dir-cache-time 10s..."

I ran 'rclone config redacted' and gott command not found. I did try the update to release v1.65 but there was no realdebrid option as there was in v1.58, please bear with me as I am new and not very technical.

The error I get when I run the command is "...NOTICE: realdebrid root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream
The service rclone has been started..."

welcome to the forum,

most rclone users that stream use --vfs-cache-mode=full
it makes the mount more compatible with the OS and programs.

can you post the output of rclone config show realdebrid:
redact id/secrets/password/etc...

and with the rclone mount command, add -vv for debug output.

Thanks ever so much for your reply, my bad I'm sorry I'm not too clear with what you are asking as when I set up I followed a guide by copy and pasting. Please can you give me an example of the command lines you have suggested?

rclone config show realdebrid: -vv

Thanks again, now I understand. I did that and got "rclone is not recognised....If you trust this command, instead type ./rclone." Did that and it displays my api-key.

run the command, copy the output into the forum, so we can see it.
ok to redact api-key, secret,password,etc...

2024/01/18 00:11:16 DEBUG : rclone: Version "v1.59.0-DEV" starting with parameters ["D:\User\Desktop\rclone\rclone.exe" "-vv"]

I thought the API key was not supposed to be shown publicly?

rclone does not support realdebrid.
for help, you need to post at realdebrid forum

Ok thanks, I did follow this.


And it worked fantastically for 5 days

the only mentions of realdebrid are

  1. type = realdebrid
    api_key = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

  2. Is a RealDebrid integration possible? #6141

You are not using official rclone but customised version.

You have to seek help with the author or community of that project. No idea what customisations they did.

Now I understand, I was puzzled I must admit. Thanks for looking and replying guys.

Glory be, I'm fixed by finally understanding how to apply --vfs-cache-mode=full.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.