--vfs-cache-max-size Issues With Windows & FreeFileSync

What is the problem you are having with rclone?

I'm running rclone on Windows 10, and using a utility called FreeFileSync to manage synchronization with some local folders and folders on Google Enterprise Drive. My main system storage is a 2TB SSD, and I'm trying to sync a secondary drive as a backup that is larger than 2TB. I'm mounting the Google Drive using the following command:

rclone mount ZDGoogle: M: --network-mode --vfs-cache-mode writes --vfs-cache-max-size 200G --no-console

The idea here is to limit the write cache to 200 gigabytes to prevent overflowing the main disk. However, with RealTimeSync (a background process for FreeFileSync) running, Rclone is still overflowing my main disk even with --vfs-cache-max-size set. Is there another option I can add to prevent the cache overflow and keep it limited? I realize it's possible to set up an Rclone task to replace FreeFileSync altogether, but I'm mainly using it as a more convenient GUI-based solution.

What is your rclone version (output from rclone version)


Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount ZDGoogle: M: ---network-mode ---vfs-cache-mode writes ---vfs-cache-max-size 200G ---no-console

Follow-up: after some research, it sounds like using an rclone mount for file syncing purposes isn't considered best practices, as the connection can be wonky in general. To better clarify what I was trying to do:

PC Main Drive: 2TB SSD (C:)
Storage Drive: 10TB HDD (E:)
Rclone Mount (M:)

I was trying to sync the 10TB HDD to a backup folder on my Google Drive with FreeFileSync, which uses a process called RealTimeSync.exe to monitor folders and keep them synchronized somewhere else. So basically, it would run in real-time and make sure drive E: would sync with rclone-mounted network drive M:.

Since this is apparently not recommended anyway, I decided to change my sync settings to only back up some small folders on my main drive, and offload the task of uploading my big 10TB drive to rclone for the time being. I may put it back in on FreeFileSync once the bulk of this drive has been uploaded, but until the file changes I'll be making on drive E: are small enough that my drive C: could easily handle uncontrolled upload cache, I'm going to use an rclone copy batch file to handle it instead.

I'm still open to suggestions for how to solve the cache overflow issue with command arguments, if possible.

You need to post a debug log and we can see what's going on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.