Very slow transfers on mount, compared with copy

What is the problem you are having with rclone?

I notice a huge difference between using "rclone copy remote:path/to/src /path/to/dst" over "rclone mount remote:/path/to/src" and copying the content from a mounted directory like this. For some reason, i blamed winfsp to be the reason since i first noted this behaviour in a Windows-system, but after a little more investigation I've expected the same behaviour using fuse in Linux. I know that fuse etc has some sort of overhead so that a slight performance-hit is to be expected, but the difference is as high as 10 MB/s -> 70 MB/s so that is not the issue here I believe.

The only conclusion I've come up with myself is that a copy from a mounted directory seems to have similar speed that "rclone copy" if i limit the transfers to just 1 at the time (i pretty much max out my connection using the default value of 4), so I'm thinking maybe the reason is that I have to make it transfer multiple files/chunks of files at the same time somehow even when using it like this? I have been trying to play around with chunk_size and caching-settings from the docs to see if I notice any difference but so far no luck.

Run the command 'rclone version' and share the full output of the command.


rclone v1.59.0
- os/version: Microsoft Windows Server 2022 Datacenter 21H2 (64 bit)
- os/kernel: 10.0.20348.887 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.18.3
- go/linking: static
- go/tags: cmount

(Edited after upgrade)

rclone v1.61.1
- os/version: ubuntu 22.10 (64 bit)
- os/kernel: 5.19.0-29-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.4
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive, Dropbox, local FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

This command works exactly as expected with good speeds:

rclone copy dropbox_crypt_test:testdir /home/DRiNKO/rclone -P -v

This is the mount-command i ran:

rclone mount dropbox_crypt_test:testdir /home/DRiNKO/rclone --vfs-cache-mode full --allow-other

The rclone config contents with secrets removed.

I have tried to play around with other options but since I only plan to use this as a read-only mount I don't think i need more than this, example for the dropbox-configuration below

type = dropbox
token = {"access_token": * REMOVED *}

type = crypt
remote = dropbox_test:/bucket/crypt
filename_encryption = standard
directory_name_encryption = true
password = * REMOVED *

hello and welcome to the forum,

need to update to latest rclone - v1.61.1

edit: did you re-edit your first post, as the version was v1.53.3?

Thank you for you answer! I did upgrade to the latest version on the current machine I'm working on and edited my original post now.

could be an issue with lack of support for multi-thread downloads when using rclone mount.

This is almost certainly correct.

You can test to see if single thread rclone copy is slower with --multi-thread-streams 0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.