Very slow sync to Google Drive

#1

Hi,

rclone is painfully slow for me syncing to google drive and I’m on 200mbps broadband. It took me several days to sync 30gb. Having done a full sync I’m an hour into another sync which still hasn’t completed. I’d hoped after the initial sync things may speed up (there have been no changes to the file since the first sync).

I’m seeing very little load on my server. Is there anything I can do to improve the performance of rclone sync or identify the bottleneck?

Thanks,

Chris

How to speed up Google Drive sync
#2

If you turn on verbose logging -vv then you can get some idea what is going on.

I’d guess that you should probably get your own client_id if you haven’t already.

Also setting --tpslimit so that drive doesn’t generate 403 errors will help.

4 Likes
#3

Thank you.

I’ve added my own credentials and set tpslimit 10 and the sync has gone from taking an hour to ten minutes. There may be a Sunday morning factor but the even so your suggestions have really helped.

Chris

1 Like
#4

Same here - client_id is magical :slight_smile: Thanks !! was afraid I couldn’t get my backup on time.

2 Likes
closed #5