Very slow Google Drive upload


#41

I’ve tested on many different computers now, with 3 different operating systems, 3 different accounts and with 3 different ISPs. All the same.

I’ve talked with Google Support that have looked through logs and settings, and told me that there are no issues on their end. They also informed me that there is no traffic shaping in place.

GoodSync instantly worked. I have limited time and Rclone has issues.


#42

If you don’t want to go further, then that is fine… But can you articulate a little more as to what operating systems you’ve tried? Are they all Windows? Windows 10? Any Linux?


#43

I understand that it’s frustrating. I don’t think it’s rclone though.

I’ve moved data using two different machine, with two different OS’.

  • rclone on an ARM based Debian Box, ACD to GSuite: ~75MBp/s
  • rclone on an x86_64 based Ubuntu Box, ACD to GSuite: ~85MBp/s

I think perhaps your testing may be flawed somehow. I had no issues (aside from the banning) moving 10TB across to GSuite.

Can you elaborate on how you had it setup/configured? At the very least, it might help others who have similar problems.


#44

Sure thing. I’ve tested Google Drive on:

  • Web (GOOD)
  • Rclone @ Synology NAS (BAD)
  • Synology NAS, Cloud Sync (GOOD)
  • Rclone @ Windows 7, 3 different computers (BAD)
  • Rclone @ Windows 10 (BAD)
  • Google Drive desktop app (GOOD)
  • GoodSync desktop app (GOOD)

Like I said, I’ve tested with multiple different ISPs, multiple accounts and I even had a friend test it as well, just to rule out myself.

I’ve tried disabling firewall, change power management, jumbo frames, disable this and that and… no change at all. Nothing.

And when other apps works right away and Rclone doesn’t work on so many platforms…

I’ve tested a lot of combinations… none have worked with Rclone, yet other apps works out-of-the-box.

Is it like what Apple said? It’s not the product it’s wrong with, it’s the user? :slight_smile:


#45

Thanks. I’m surprised to see the Synology in there… I’ll try to recreate your problem on the Windows platform. It really would be good to narrow it down…


#46

I tried it on 1 Windows 7 machine and one Windows 7 Virtual box VM. Performance on both is fine. My linux installs are a bit faster but Windows works fine. I was getting around 5-7MB ona a quick test. idk.


#47

Seeing what you’ve written, it makes me think that there may be a much larger issue than rclone. It seems extremely odd to me that both @calisro and I have had next to no issues, where you seem to have all the issues.

Silly question, but could it be the other applications use UPNP, where rclone does not? Or a firewall issue perhaps? It seems logical that there would be an issue with the pipe, considering it seems to effect all of your combinations of rclone testing setups.

I just cannot replicate the issues you’re seeing.


#48

I’m also experiencing slow upload to Google Drive at 3-4 MBytes/s when uploading single files. While my upload speed is faster than 700 kBytes/s, it’s still much slower than I would expect. I have worked around the problem by uploading many files in parallel until my connection is saturated.


#49

I’ve got the same issue. Used to work at high speeds (~300 Mb/s), now with the same settings, about 350 kB/s (2.4 Mb/s) per transfer. I am using my own Dev ID, on windows. I tried the built in Dev ID, same thing.

I tried a different connection, same issue. But trying a different computer, it is ok, sometimes. Wierd?!?


#50

Further for this, I’ve found the ISP is making a difference. VPN out to a different connection allows faster speeds again. So it’s either a ISP or google throttle.

It is definitely a throttle, because the transfer rate graph is dead flat, no variation in speed at all.


#51

I’m getting the same on a 10Gbit network…


#52

I am seeing the same issue as well on a cubox-i running ARMBIAN 5.25 stable Ubuntu 16.04.2 LTS. I am not sure how to debug it. :confused:


#53

Not much to do… Even though many people are having the same issue, Rclone claims that there is none.


#54

That isn’t quite correct and you are in control of your own debugging. I unsuccessfully tried to recreate your problem on windows so that I could help you debug and I couldn’t but as you can see above people are trying to lump ‘slowness’ all together across platforms. @jbreitbart is trying to run this in a cubox-i box. What would be considered ‘slow’ on that tiny box? Should I try to compare my fireTV to my Ubuntu server? Threads that try to lump symptoms together like this are never successful. I’m not saying rclone doesn’t have an ‘issue’ somewhere… What I am saying is that it seems to work ok for me on Windows, Ubuntu, VIrtualbox (windows), firetv, firestick (a little slow here but the wifi on these things are awful), my LG G5 android phone, my Raspberry pi Gen1.


#55

Obviously slow is relative. For me that was a few bytes per second whereas upload to Amazon drive was about 10 MBit/s on the same hardware. If you have useful advise on how to debug this let me know. Comparing the performance with your android phone seems not very productive.


#56

Not having an issue:
2017/06/13 18:57:03 INFO :
Transferred: 504.396 GBytes (3.340 MBytes/s)
Errors: 1
Checks: 167
Transferred: 144
Elapsed time: 42h57m1.3s
Transferring:


#57

@jbreitbart what’s your setup look like? wifi or Ethernet? What download speed do you get with others utilities such as downloading with curl? Is it only rclone? I’ve heard the wifi modules in those things aren’t great… Try Ethernet. Also how is your memory look while uploading? Are you swapping? Tried with a small number of transfers?

Could it be ipv6?

It may be worthwhile to try another utility to copy to Google. See what that brings…

Or even something simple and not-fuse like:


#58

I’m still having an issue with this, on a windows 2008 R2 computer, it’s an old AMD Neo chip, slow but fine for a server. Using this to upload, 60,000 files about 6TB, it initially ran fine, 200Mb/s upload speeds, then, perhaps when the file count grew, it started slowing, now it’s about 400kb/s per upload.

Plenty of spare CPU and disk capacity, increasing the transfers flag just adds in more and more ~ 400 kb/s streams.

Using a newer computer, windows 10, and uploading to GDrive from a network share of the first one, gives single file speeds back in the hundreds of Mb/s, back to normal.

Not sure if its self throttling or what to try now on the slower computer. As I said, the initial seed ran fast on that computer.

Any ideas? Thanks.


#59

Sorry to rescue an old topic…

Here it’s really slow too. I tried it both in Chromium and Firefox Nightly too…


#60

Same here. Upload speed from local to GDrive is just 134.282 kBytes/s. Ubuntu Server 16.04, rclone version 1.39, i7-5960X CPU @ 3.00GHz, 128GiB RAM