Using spaces in folder-name

What is the problem you are having with rclone?

I'm setting up a transfer between a local folder and my google drive.
The folder is called TV Shows, and Rclone is causing me a lot of trouble because of the space in the name.

I've tried using " " and ' ' around the name, but nothing helps.

It's probably just some super small error, but I'm new to this so any help is welcome.

What is your rclone version (output from rclone version)

rclone v1.51.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

The "transferring movies" seems to give no problems. The "tv shows" does however cause some problems.

#!/bin/bash

echo "Transferring movies"
/usr/local/bin/rclone move ~/media/Movies/ gdrive:/Movies --progress 

echo "Transferring tv shows"
/usr/local/bin/rclone move '~/media/TV Shows/' 'gdrive:/Series' --progress 

I have also tried the following:

#!/bin/bash

echo "Transferring movies"
/usr/local/bin/rclone move ~/media/Movies/ gdrive:/Movies --progress 

echo "Transferring tv shows"
/usr/local/bin/rclone move "~/media/TV Shows/" "gdrive:/Series" --progress

Can you share the actual error you getting?

You can single ' spaces.

felix@gemini:~$ rclone ls /home/felix/'TV Shows'
      413 hosts

as an example.

Also it's generally better to use full paths rather than "~" but that won't break anything per se.

Yeah so just like you said, the quotes should only be around the name of the folder, not the whole path.
I feel stupid for not trying that out and sitting with such a small error for so long...

Thank you so much @Animosity022.

What did you type before? Quotes on the whole thing should work to.

felix@gemini:~$ rclone ls '/home/felix/TV Shows'
      413 hosts

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.