Using b2 via rclone mount as storage for Plex, but Plex can't see the mount

What is the problem you are having with rclone?

Plex sees the mount /net/b2/plex/ as a file called plex - and if I select a parent directory above that, it does not find any media.

I am running Plex on a VPS. I have successfully mounted the b2 bucket. When I

ls /net/b2/plex

I can see and access all the media.

The Plex server is successfully running and I can see the server and try to add libraries in the Plex web UI.

What is your rclone version (output from rclone version)

rclone v1.53.0

  • os/arch: linux/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu server 20.04.1 LTS

Which cloud storage system are you using? (eg Google Drive)

Backblaze b2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount b2:plex-vps/ /net/b2/plex --daemon

The rclone config contents with secrets removed.

 
[b2]
type = b2
account = (redacted)
key = (redacted)
hard_delete = false

A log from the command with the -vv flag


2020/09/18 17:27:17 DEBUG : rclone: Version "v1.53.0" starting with parameters ["rclone" "mount" "b2:plex-vps/" "/net/b2/plex/" "--daemon" "-vv"]
2020/09/18 17:27:17 DEBUG : Creating backend with remote "b2:plex-vps/"
2020/09/18 17:27:17 DEBUG : Using config file from "/home/chris/.config/rclone/rclone.conf"
2020/09/18 17:27:18 DEBUG : fs cache: renaming cache item "b2:plex-vps/" to be canonical "b2:plex-vps"
2020/09/18 17:27:18 DEBUG : rclone: Version "v1.53.0" finishing with parameters ["rclone" "mount" "b2:plex-vps/" "/net/b2/plex/" "--daemon" "-vv"]

Are the rclone user and plex user the same? If not, you need to add allow-other to your mount command.

1 Like

Thank you. However, after trying this, adding --allow-other just makes the mount fail. To be clear, the rclone command works without errors, but then I cannot see any files within the mount. Removing the --allow-other option successfully loads the mount and then I can see the files.

To clarify, I am running the rclone mount command and the plex server with the same user, too.

If you have the mount running, do you see files?

ls -al /net/b2/plex

shows what?

and if you check plex.

ps -ef | grep -i plex

Share those outputs.

Okay thank you. Here are the outputs. This is with the mount running (but not with the --allow-other flag)

(Side note, bucket 'plex-vps' is actually now called 'plex-vultr')

ls -al /net/b2/plex

total 32268
drwxrwxr-x 1 chris chris        0 Sep 18 19:39 music
-rw-rw-r-- 1 chris chris 33042355 Sep  7 17:39 wu.flac

This shows a folder (music) and a test file I placed in the bucket.

ps -ef | grep -i plex

plex         605       1  0 19:36 ?        00:00:01 /usr/lib/plexmediaserver/Plex Media Server
plex         776     605  1 19:36 ?        00:00:03 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-a78fef9a9/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 1.20.1.3252-a78fef9a9 /usr/lib/plexmediaserver/Resources/Plug-ins-a78fef9a9/System.bundle
plex        1028     605  0 19:37 ?        00:00:00 /usr/lib/plexmediaserver/Plex Tuner Service /usr/lib/plexmediaserver/Resources/Tuner/Private /usr/lib/plexmediaserver/Resources/Tuner/Shared 1.20.1.3252-a78fef9a9 32600 /waitmutex
plex        1052     605  0 19:37 ?        00:00:01 Plex Plug-in [com.plexapp.agents.imdb] /usr/lib/plexmediaserver/Resources/Plug-ins-a78fef9a9/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 1.20.1.3252-a78fef9a9 /usr/lib/plexmediaserver/Resources/Plug-ins-a78fef9a9/PlexMovie.bundle
plex        1083     605  0 19:37 ?        00:00:00 /usr/lib/plexmediaserver/Plex Relay -p 443 -N -R 0:127.0.0.1:32401 -o StrictHostKeyChecking=yes -o UserKnownHostsFile=/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Cache/relayHostKey.txt -o LogLevel=VERBOSE -o PreferredAuthentications=password -o PubkeyAuthentication=no -l christopher.doherty@gmail.com -F /dev/null 172.105.3.158
chris       1421       1  0 19:39 ?        00:00:00 rclone mount b2:plex-vultr /net/b2/plex --daemon -vv
chris       1438    1249  0 19:40 pts/1    00:00:00 grep --color=auto -i plex```

You are running plex as the 'plex' user and rclone is running as 'chris'.

You need to run allow-other to allow another user to access a fuse file system, which rclone is.

1 Like

you might need to edit the /etc/fuse.conf file to enable that flag.
remove the # from #user_allow_other
https://github.com/libfuse/libfuse/blob/master/util/fuse.conf

2 Likes

Thank you. This worked. I was able to edit fuse.conf and then rclone worked with the --allow-other option. Now Plex sees the mounted storage.

really, @Animosity022 solved it, i just offered a way to implement his solution

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.