Using --allow-root results in fusermount: mount failed: Invalid argument

#1

I’m trying to use --allow-root and I’m also running rclone mount as root.

This works:

rclone mount remote: /home/files

This doesn’t work:

rclone mount remote: /home/files --allow-root
mount helper error: fusermount: mount failed: Invalid argument
Fatal error: failed to mount FUSE fs: fusermount: exit status 1

My /etc/fuse.conf has user_allow_other on it. System is Ubuntu 18.04 and remote is google drive.

#2

What does rclone version show?

#3

It’s latest, I just installed it… v1.47.0

#4

Yeah, that seems baffling as it should work. I can reproduce it as well.

You can work around by using --fuse-flag allow_root

Probably best to file a bug report on it:

[felix@gemini ~]$ rclone mount GD: /Test --allow-root --debug-fuse -vv
2019/05/10 23:28:09 DEBUG : rclone: Version "v1.47.0" starting with parameters ["rclone" "mount" "GD:" "/Test" "--allow-root" "--debug-fuse" "-vv"]
2019/05/10 23:28:09 DEBUG : Using config file from "/opt/rclone/rclone.conf"
2019/05/10 23:28:09 DEBUG : Google drive root '': Mounting on "/Test"
2019/05/10 23:28:09 mount helper error: fusermount: unknown option 'allow_root'
2019/05/10 23:28:09 Fatal error: failed to mount FUSE fs: fusermount: exit status 1
1 Like
#5

Seems this is quite old. Thanks for the workaround

#6

This looks like a bug...

In fact it has been reported upstream

There is a work-around there...

Can you please make a new issue on github about this - thanks.