Uptobox configuation

What is the problem you are having with rclone?

Hello, I would like to use RClone with Uptobox on a NAS Synology. I can't find any help installing the service. Can you help me with the procedure please? Rclone is installed and the link (Token) with Uptobox too. But I cannot create the synchronization in a folder of the NAS.

What is your rclone version (output from rclone version)

Latest version on Docker

Which cloud storage system are you using? (eg Google Drive)

I would like to use "Uptobox"

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I don't have the command, it's my question I think

Thank for your help

hello and welcome to the forum,

if rclone is installed then you can run any rclone command you want.
rclone sync is documented here

1 Like

thank you @asdffdsa for your answer, but I don't understand how mount the folder on my nas

so you want to run rclone mount on the synbox?

i use this script to
--- create rclone mount
--- share that rclone mount over the lan, vpn or tailscale.

log="--log-level=DEBUG --log-file=$logfile"

fusermount -uz $mountpoint

rm $logfile

rclone mount remote: $mountpoint --allow-other --vfs-cache-mode=full --cache-dir=$cachedir $log --config=$configfile

Thank you for the help I am not far from the goal.
Now I have this error message coming up and I can't seem to fix it.

How do I run the script you gave me?

I succeeded my files appear in my synology! Thank you!
How to view current connections and delete them?

  • view current connections:
    ps aux | grep "rclone mount"
  • delete them:
    documented here

Thank for your help, it's perfect!

@asdffdsa just an another quesion sorry...
Rclone works fine, but it took a long time to scan files in plex. Are there any parameters that could speed this up?
This is my configuration:

#mountpoint='/volume1/"Plex base de donnée"/Uptobox/Uptorenommer'
mountpoint='/volume1/"Plex base de donnée"/Uptobox/Uptorenommer'

fusermount -uz /volume1/"Plex base de donnée"/Uptobox/Uptorenommer

rclone mount upto:Renommer /volume1/"Plex base de donnée"/Uptobox/Uptorenommer --allow-other --vfs-cache-mode=full --allow-non-empty --cache-dir=/var/services/homes/Kevin/.cache/ --config=/var/services/homes/Kevin/.config/rclone/rclone.conf

Do we need to add a condition?

Thank for your help

it depends on what settings plex uses to scan media files and settings used for scheduled scans.
for example,

  • Enable Thumbnail previews - plex will have to scan the entire media file and force rclone to download the entire media file.
  • Perform extensive media analysis during maintenance - same thing, plex will have to scan the entire media file and force rclone to download the entire media file.
  • i do not use plex but @VBB might have a suggestion?

--allow-non-empty should be removed, allows for over mounting

Ok thank you, I tried adding the "--no-modtime" parameter, looks like it is a little better

When you say the scan takes a long time, how long exactly and how big is your library? Just using the new Plex scanner/agent combo sped things up for me significantly.

For use with Plex, I would not use the --no-modtime flag, btw. It can mess things up during scans, because (at least on GDrive) every file will have the same time and date as the parent folder.

no modtime would break plex as it uses modtime to figure out if the file changed.

I have 20to on my nas and 3to of series on Uptobox(For now, it's a test with Rclone). When plex (or Emby) scan the library the 20to take 5minutes and the 3to 1hour ... I don't know why
I have the impression that it rescans all the files that are on rclone each time

I don't know what you are running or not running at this point.

If you change paths on plex, it readds the file.
If you change file size, mod time, it analyzes the file.
If the file is already analyzed and none of those things change, it does not analyze it and moves on.

A fully analyzed library on Linux takes seconds to a minute depending on size of the library and your library is rather small.

  • plex/emby might be scanning on a schedule. i always disable all scheduled tasks.
  • --no-modtime - if you had used that and then removed it, perhaps that caused plex/emby to rescan the entire media library.
  • as per rclone docs, uptobox does not support modtime and hashes. not sure how plex would handle that.

so not sure how plex interacts with uptobox without using modtimes?

Your screenshot indicates that Plex is treating those files as new, hence the "traitement terminé" notification ("finished processing"). Like the guys already said, get rid of --no-modtime and let a scan finish completely, then run another one to see if anything is different. If you haven't already, check out the many threads here where all three of us have helped users with Plex + priming, etc. Let us know how everything goes.

Now that I think about it, are you using separate libraries for NAS and Uptobox? Do they have overlapping content? I would imagine Plex treating the files on Uptobox as new, if you have the same content on the NAS already and the libraries are the same.

I removed "No modtime" and "allow no empty". But I have the impression that the files which are on Uptobox are constantly updating. I ran two analyzes in a row without touching the library. and yet he reanalyzes everything.
When I am in the explorer and I refresh the files, the time is always the current time (See image, time 13h47, if I refresh the page at 13:50, the file will have the time of 13:50) I think that is why it rescans everything every time

After a few tests, I put the no modtime mode back. And for the moment that makes it work better, the date does not change constantly. I'll see what happens in the long run

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.