Upload to dropbox

Hi there! Sorry if the question is a very basic one, but i am very new to rclone and coding it self. what i am trying to do is upload files from my raspberry to dropbox, but i am having trouble getting it to work.

this is the code ive tried ("upload" is the name of a folder on Dropbox):
rclone copyto Dropbox:upload /home/noah/Desktop/testing/2022-06-08_13-24-22_UTC.mp4

this is the error I get:

2022/06/09 17:23:43 Failed to create file system for "Dropbox:upload": didn't find section in config file

Ive also tried: rclone copyto /home/noah/Desktop/testing/2022-06-08_13-24-22_UTC.mp4 Dropbox/upload

with this i dont get a error message and nothing happens.

rclone version:
rclone v1.53.3-DEV

  • os/arch: linux/arm
  • go version: go1.15.5

any help would be highly appreciated!
thanks in advance!

I have no idea if it will fix your problem but you are using a super old version of rclone. Please update and try again.

Also, this will make a file locally from the file called upload.

It is

rclone copyto <SOURCE file full path> <dest file full path>

Hi there! sorry unintentionally replied in the wrong language... First of all, thank you very much for replying! I will update rclone and try it again. what would be the right command/code to upload a file to dropbox?

thanks in advance!

Did you run rclone config to create a remote called Dropbox? You might have called it something else - you need to use that name (it is case sensitive).

What does rclone listremotes say?

ohh i didnt know that, yeah i called mine "updrop", where do i need to put it in the code?

thank you in advance!

Assuming you are trying to copy the mp4 to dropbox into the folder upload you want

rclone copy -P /home/noah/Desktop/testing/2022-06-08_13-24-22_UTC.mp4 updrop:upload

If you ever aren't sure what you are doing with rclone add the -i flag and rclone will prompt you for confirmations, so I'd suggest the first thing you run is

rclone copy -i -P /home/noah/Desktop/testing/2022-06-08_13-24-22_UTC.mp4 updrop:upload

It worked! thank you very much!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.