Upload speed for G-Drive Rclone (extremely new to command and scripts)

Hi all, I have tried to look for answers but to no avail as I am absolutely new to command, scripts or even rclone. I have used rclone browser for the past year without any changes as it was a drag and drop function that was easy to grasp.

Well, ever since the error that google came out with past week on the "user-agent string" or something, I realised that using rclone (not the rclone browser) will be viable solution in the long run. I have read the website and watched youtube videos to try and understand the complexity (or some would say simplicity) of the system, and appreciate the assistance you would provide me with.

I am running on a Gigabit connection and have had no issues reaching 60-70MB/s upload speed on rclone browser previously without any changes or tweaks. This past week, the speed barely moved to 1MB/s. It was more of a 200-400KB/s and I have not hit the 750GB cap or anything as I am unable to upload anything over the past few days. Correct me if I am wrong in the flow that I am using after I have set up the new remote.

  1. mount gdrive to rclone on my windows 10 using:
    rclone mount test:/to/files X: --user-agent "letmeupload"

  2. rclone copy --verbose d:\files test:\ --user-agent "letmeupload" --transfers=8 --drive-chunk-size=128M -P --log-file --stats

I have extremely limited understanding of how the system should work but nonetheless, there are 6 files in the folder (each around 50GB) and the combined upload speed was barely 1MB/s. Something wasn't right and I have no idea to fix it. I am clueless for generating own API or how to insert it if it is needed. I am running on windows 10, on 24gb ram and i7 7700hq. Appreciate all the help I can get on this.

edit: I have also used GDFS and browser but they were quite slow too.

For Google Drive, you want to make sure you use your own client ID/API Key:


You do not need to copy to the mount to step as you can copy directly to the mount.

rclone copy D:/Something RemoteName: -vv

Can you the copy with the -vv and share the output? transfers 8 is a bit much as you can only create 2-3 files per second on Google Drive.

I have use my own client id and client secret. Mounted rclone. The speeds are horrendous still.

Any help appreciated now.

Setting --drive-chunk-size 64M will speed things up at the cost of some memory. I don't know why it is running so much slower than it did though...

Hi @ncw. I have inserted that at the end as well but the speeds remains as it is. I have not hit any 750GB upload limit as I am still able to download from it as per normal. Just this upload has been bugging me over the past week.

Probably not rclone unfortunately as it’s probably something in your local setup / ISP as you are not getting any errors from those logs.

Can you share a full log?

Hi @Animosity022, how do I share the full logs? I have tried running on VPN as well prior to this and was having more ore less the same speed. As shared earlier, there wasn't any changes made to the system or connection when I was running RClone Browser. It was this week when there were a lot of people having 429 error or something from google that requires user to change the user agent name.

You can write it to a log file and use dropbox/pastebin/any file sharing method of your choice.

The 429s were errors in the log and a throttling from Google. You aren't seeing those in any log you've shared so that would not be it.

Oh yea, sorry. As I'm still new to this, how do I enable or retrieve the logs yup

You can add "-vv --log-file name.log" and that should produce a log file.

Thanks @Animosity022, will try that soon. Just to confirm, the upload limit is 750GB for total file size. What if you have more than 1000 files but adds up to less than the limit? Say all of which are word documents or music? Will that trigger API count hit therefore needing to wait 24 hours?

Yeah, it's 750GB per day and doesn't matter what the contents are to my knowledge.


Am starting to feel it's an issue with my config file (to which I have deleted RClone and redownloaded again, but same problem. Ran a VPN but speed remains as it is to which I deduce it's my PC. I tried uploading from a different PC at a mate's house and it was still slow as hell (but a major upgrade from 500KB/s to 3MB/s). Emailed my ISP for any issues to google but there wasn't any.

edit: I tried using a spare laptop at home with rclone and was able to upload normally, prolly around 30MB/s for each file. Yet to test more than one at a time. So it is not my ISP issues but rather PC. Any idea how to "clean" or "reset" rclone config? I've tried clear cache and deleted rclone, redownload and run but still same issue persists.

There is not much that sticks around from rclone.

You can delete the rclone.conf and start over, but doubt that would change much if you are having a problem on your PC.


I've tried deleting rclone, disabling firewall, uninstalled things that may be of conflict and even used CCleaner to "patch" things up on my PC, along with Windows Defender. Still, it doesn't work on this PC but works fine on the other one at home (sort of a thrown away pc).

If you are working on one PC and not another, you at least know what the issue is. I'm a Mac user so I can't offer much advice on the Windows side unfortunately.

Guess I got it figured out! When I turned on my VPN, the DNS auto changed to theirs, and it remains even when I disconnect (which is weird) and exit the programme. Have inserted Google's DNS and speeds are back to normal for now. It went as high as 90-96MB/s for 4 files, but dropped thereafter to around 40-50MB/s. Guess that's normal?

1 Like

Normal is a strong word as it depends on what it is doing. 40-50MBs seems pretty good.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.