Update version Rclone Synology

Hi friends,

I have rclone 1.35 in my synology. I want update to 1.36 but i don’t know what commands i have to execute to upgrate or to uninstall and then install


just replace the rclone binary with the latest version. nothing else is needed

thanks Seaffert, work fine

How did you install rclone on synology?

Hi Hari9,

copy files into Synology [1]

connet Putty whit root (Sudo –i)

cd /volumen1/xxxx/yyyy/ [1]
sudo cp rclone /usr/sbin/
sudo chown root:root /usr/sbin/rclone
sudo chmod 755 /usr/sbin/rclone
sudo mkdir -p /usr/local/share/man/man1
sudo cp rclone.1 /usr/local/share/man/man1/
sudo mandb


i have detail manual in spanish

1 Like

Hi Iñaki,

Could you send me the manual you have?



Hi Cesar.


1 Like

Thank you so much. I’ll give it a try once I have my new synology up and running.

Any chance that you could post in english how you did?

Cheers :slight_smile:


Are you comfortable using ssh to connect to your nas and do you need the rclone mount functionality?

Hi Blim.

SSH is ok :slight_smile:

Just curious of what I need to do how to install it.

Well if I need to use my googledrive / Amazon etc … i asume mount is needed. :slight_smile:



Ok, This is what worked for me (ymmv)

It was a little while ago, but what I did was firstly add the syno community to the package manager and installed sshfs (I think it should advise if you need any additional packages, I can’t remember) I did this to ensure the fuse libraries were available. As you need that for the mounting

I also have homes setup so my admin account has a folder


What I would do first is install rclone on your desktop machine, add your remote(s) and make sure its all working, then when ready you can simply copy your config file to the nas

Then you can pretty much follow the standard install.

I logged into my nas with the admin account

from within the folder /volume1/homes/myadmin

I ran

curl -O https://downloads.rclone.org/rclone-current-linux-amd64.zip

as unzip could not be found I had to use Filestation to unzip the downloaded file

Change to root account

sudo -i

change back to the rclone folder in your admin directory

cd /volume1/homes/myadmin/rclone-v1.36-linux-amd64

cp rclone /usr/bin/
chown root:root /usr/bin/rclone
chmod 755 /usr/bin/rclone

exit out of the root account back to your standard admin account

and cd to your home directory (just in case you are not in it)

if it does not exist, create the following folder structure inside your home directory

once thats created, go back to filestation and navigate to .config/rclone directory in your home directory
and upload the config file from your desktop machine

Once done go back to your ssh window
and run rclone config, you should see your remotes that you set up using rclone on your desktop machine.

Now your standard rclone commands should work.


Ahhhh thank you so much . :slight_smile:

So installing Bootstrap for Synology is not needed at all?

Gonna test it out tomorrow .



ha, thats always what put me off, then i found sshfs in syno community which I know needs the fuse libraries. So installing that made all the pain go away :wink:

You can use 7z to unzip the file, which means you can basically follow the linux install instructions on the rclone website exactly.

Would be nice if there was a brew install for rclone though!

Looovely :slight_smile:

Cheers for the info guys ^^


Ok ran into some problems.

I dont use homes folder , since im the only user on the nas.

When I use rclone config, I get this :slight_smile:

2017/05/21 17:21:23 NOTICE: Config file “/var/services/homes/Morphy/.rclone.conf” not found - using defaults
No remotes found - make a new one

But those folders are not present since I dont use home/homes. Its working fine with root, but how do I solve this minor issue not having homes?

Thanks :slight_smile:

So which directory are you in when you ssh into your nas?

Maybe try creating this directory structure " .config/rclone" in the directory you are in when ssh’ed in

and try rclone config again

Or you could specify a config file with the --config=/path/to/config option

Outside my /volume1 :slight_smile:

Oh so if its located under /root/.config/rclone/rclone.conf I can just do like this:

Rclone --config=/root/.config/rclone/ copy gcd:Backup /folder/where/i/want/myfiles? :slight_smile:

Thanks :slight_smile:

Dont think it would work since its located under root - and users dont got access to root folder?