Union with sftp and local folder in windows

What is the problem you are having with rclone?

As i am using windows, i am using rclone union to mount a local folder and remote folder (sftp) (read only). The issue is sometimes the import in radarr fails. first it says file does not exists so import fails, and right after that the log says file already exists. Also performance is not good.

System.IO.FileNotFoundException: File doesn't exist: <full path of media destination>
Warn|ImportApprovedMovie|Couldn't import movie <full path of downloaded media>
NzbDrone.Common.Disk.DestinationAlreadyExistsException: Destination <full path of media  destination> already exists.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.0-beta.6930.927e721a2
- os/version: Microsoft Windows 10 Enterprise LTSC 2019 1809 (64 bit)
- os/kernel: 10.0.17763.2061 Build 17763.2061.2061 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

SFTP, Local folder, Rclone Union

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I have tried different mount combination, specially with vfs cache and dir cache time, i want change to be reflected asap.

rclone mount fused: f: --volname fused -buffer-size 1G --dir-cache-time 1m  --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off --vfs-cache-mode writes --cache-dir "d:/cache" --vfs-cache-max-age 1h --poll-interval 1m

What i've seen is if i enable vfs cache then the file seems to be copied in the fused dir, after the copy finishes, a 0 byte file is created in the local drive and after sometimes the file comes into local drive fully. i guess first the file is copied to cache than from cache it is copied(?) to local drive. With vfs cache off it shows

WriteFileHandle: Truncate: Can't change size without --vfs-cache-mode >= writes
WriteFileHandle: ReadAt: Can't read and write to file without --vfs-cache-mode >= minimal

in log bt the file is copied even with error locally directly.

The rclone config contents with secrets removed.

type = sftp
host = <removed>
port =  <removed>
user =  <removed>
pass =  <removed>
key_file_pass =  <removed>
shell_type = unix
md5sum_command = md5sum
sha1sum_command = sha1sum

type = union
upstreams = d:/media sftp1:/mnt:nc

Importing worked with,

With cache (full/writes) + high dir cache time (30m/1h)
With cache off + a low (1m) dir cache time

It would be great help if help me to have an optimal mount setting or any other alternative of rclone union to combine the sftp mount with a local folder. also there is no icon on the mount on windows explorer.

no one?
anyone can suggest an unionfs like alternative for windows ?

Sorry as I use Linux for use cases like that and would avoid Windows.

yes i have other servers running on linux but i need this one with windows. the rclone implementation is not great but i could not find any exact alternative

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.