Union root folder, or virtual folder

Hi, i have my remotes in union, 1 crypt remote, and 1 non crypt. Actually these both are on the same remote.

Relevant part of config:

[1fichier]
type = fichier
api_key = XXX

[1fichunion]
type = union
upstreams = hasher1fichier:/ 1fichier:/noncrypt/

[backupkript1fichier]
type = crypt
remote = 1fichier:/crypt/
password = XXX
password2 = XXX

[hasher1fichier]
type = hasher
remote = backupkript1fichier:/
hashes = md5,sha1,whirlpool

Nor the "crypt", or the "noncrypt" folders are visible from union, so i'm thinking about how rclone decides if i create a new folder in union root, then it belongs to the "noncrypt" folder, or the crypted folder?

Is it possible to include the referenced folders too in union? So in this case to see the content of the crypt, and folder noncrypt, instead of the contents of noncrypt?

Or to create virtual folders to see the limitis of the underlying remotes? For example the crypted remote to be in folder "thecrypt", the other in "notcrypted"?

Based on policies. mkdir will be driven by create policy - by default it is epmfs - "of all the upstreams on which the relative path exists choose the one with the most free space.".

Are you sure you want to use union? Its purpose is exactly to hide all underlying remotes and present them as an union:) Maybe combine remote is what you should look at - then you can create virtual folders pointing to deferent remotes.

Example:

[combine]
type = combine
upstreams = thecrypt=backupkript1fichier: notcrypted=1fichier:noncrypt

Unfortunately combine seems to be bugged with 1fichier: i get messages like these 2024/01/20 12:53:55 ERROR : nonkripta/20200225_135330.JPG: Entry doesn't belong in directory "nonkripta/moccvid/2020/20200225" (too short) - ignoring

all files are missing from folder "moccvid", only folders are visible, but even some folders are not visible. All visible from union/ or if i open the remote directly.
here is the combine setting:

[1fichunion2]
type = combine
upstreams = kripta=hasher1fichier:/ nonkripta=1fichier:/nemkripta

Nobody can see what you are doing and what this error relates to.

Do not use "/" after remote names, so:

[1fichunion2]
type = combine
upstreams = kripta=hasher1fichier: nonkripta=1fichier:nemkripta

Then run for example

rclone ls 1fichier:nemkripta

and

rclone ls 1fichunion2:nonkripta

Both commands should produce the same results.

removed "/"s, the results not changed, so not the same for the 2 ls commands, see the errors above, same files same folders are Entry doesn't belong in directory while all obviously do.

I have replicated your exact combine setup (mixing crypt and no crypt on the same remote) and everything works as expected. Zero issues - nothing is missing, no errors. I have tested with two different remotes (onedrive and S3)

It is possible that 1fichier has some issues/bugs not present at other remotes. Maybe some other 1fichier users here can try setup similar to yours and help to identify the problem.

Unfortunately 1fichier requires premium subscription to use the API so I am not able to test or investigate further.

BTW 1fichier does not look like service people rate well...

In addition looks like it is blocked in many countries.

They are certainly a very problametic host with very "interesting" ideas of support. I tried using it as a secondary backup source and let's just say if I wasn't bald I'd be still having no hair. IP blocking on a whim and the support refusing to even give information to help you reduce the issue ("security" ha) doesn't help.

There's no security risk saying your IP ending with 123 made 455 calls in one minute or something [made up example] to help you look at say transactions or activity, but "you raised a security issue, fix it, the longer it goes on the longer we block" is hardly helpful.

They are, of course, cheap for a reason.

I'd try and run a test but for the foreseeable future I'm a bit tied up and, in any case, the last time I tried the IP was blocked....

1 Like

these problems for me only happen in combine, but not in union, or without these