Union mount with VFS & Cache w/ Plex Windows


#1

Hi guys!

First off, sorry if this post is a bit choppy, as I am writing it from my phone.

I have a VPS which is running Windows Server 2016 as I use it for things other than Plex. Currently, I have setup Google Drive, Cache, and Crypt. Also a crypt not wrapped with cache.

My config looks like this:

  1. Gdrive:
  2. Gcrypt: (this is just a folder for other encrypted files
  3. PlexCache:
  4. PlexCrypt: (wrapped with PlexCache)
  5. PlexCryptNoCache:
  6. Union: (PlexCryptNoCache:/ PlexCrypt:/) - in that order.

When I initially had my setup with the crypt wrapped remote, I was able to let plex scan as many times as it wanted, and it always pointed to the database for any changes. I also had implemented a —cache-temp-upload with a —cache-temp-wait-time. With these settings, plex would scan instantaneously, making no calls to google, catching the changes marking them almost instantaneously, then sending the program to the drive.

In trying to reduce overhead on the VPS, I setup a Union of VFS and the wrapped crypt cache.

The settings I use to mount the union are (–no-checksum --no-modtime --vfs-read-chunk-size 8M --buffer-size 0M --volname “Plex Drive” --tpslimit 3).

My understanding is that if you don’t specify a write to the VFS, it remains as a read only. In addition, listing it first in the union makes it a read only. Making my cache read/write.

The issue I’m having is two fold. One, when watching a program off the union, plex works rather quickly. However, it’s catching chunks into the backend and buffering the players a good 5-10 min unlike VFS. This wastes bandwidth, and creates the unwanted overhead. Two, when I write to the union, uploading new programs to plex, how can I get plex to scan the cache db so that it’s not making calls to the google’s api, again wasting tons of bandwidth.


#2

You’ve got quite a complex setup there. Why don’t you simplify it according to this setup?