Union local write only doesn't update when local is deleted

What is the problem you are having with rclone?

not sure what command to use

What is your rclone version (output from rclone version)

latest as of 19/12/20

Which OS you are using and how many bits (eg Windows 7, 64 bit)

windows 10

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

So my question is union with local write, i have all that bit working. but when i then rclone move the files to the gdrive, the union doesn't update. nor does it update when i delete them from local, i don't need vfs or cache, but just need to know what commands i need fdor it to update as soon as i have changed the local etc



We aren't sure what version / command you are using for this.

If you can share the stuff in the template, it really helps out.

OK no problem so:
rclone v1.53.3

  • os/arch: windows/amd64
  • go version: go1.15.5

type = union
upstreams = d:\plex crypt1::ro
action_policy = epall
create_policy = eprand
search_policy = ff

the command i am using is simple and basic as
rclone mount uniontest: t: --rc

although i have tried it with vfs full/write, i've tried dir-cache-time, rc vfs/refresh and many others and i just can't get the union to refresh whats been deleted/moved in the background from the local drive at all..

Any tips ?


Share the rclone.conf
Share a log file with debug.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.