Unable to use base64 encode

What is the problem you are having with rclone?

Run the command 'rclone version' and share the full output of the command.

rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.18.1

Which cloud storage system are you using? (eg Google Drive)

IDrive e2


type = crypt
remote = idrive:main
filename_encoding = base64
password =

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -v "/home/main" "idrive_main_b64:"

<Error><Code>XMinioInvalidObjectName</Code><Message>Object name contains unsupported characters.</Message><Key>pvk6juggg8bj046cmc0m0hf0p8/is9i0376v2euagela1n1noeov4/e171t752gpq1sb2kcj0sh5om9pau0ccshvtn2nh6jjptgovb3d3vf8kkrv3u5qoe0mc4a5i8eq97q1rotb8juh8mejnaarg1rbja0lsafcdhbdka2764stkvksapq49781n820gugqpnbbh0dcmle4elfugqlm6gr0g3dqgl04m2mb5naj29pq2ign6o2jekn8ium9ff9erh2koa62mjodsaf1ssmj6jklh1f4rrov7ljh18l14euu4s2uc1adi7sl9jdd0mh29lpqcj5q8bdm7t5f7u97bgub88ehft414er88rfo9g</Key><BucketName>main</BucketName><Resource>/main/pvk6juggg8bj046cmc0m0hf0p8/is9i0376v2euagela1n1noeov4/e171t752gpq1sb2kcj0sh5om9pau0ccshvtn2nh6jjptgovb3d3vf8kkrv3u5qoe0mc4a5i8eq97q1rotb8juh8mejnaarg1rbja0lsafcdhbdka2764stkvksapq49781n820gugqpnbbh0dcmle4elfugqlm6gr0g3dqgl04m2mb5naj29pq2ign6o2jekn8ium9ff9erh2koa62mjodsaf1ssmj6jklh1f4rrov7ljh18l14euu4s2uc1adi7sl9jdd0mh29lpqcj5q8bdm7t5f7u97bgub88ehft414er88rfo9g</Resource><RequestId>17B5EFD43B0BD49A</RequestId><HostId>xxxxxxxxxx</HostId></Error>

The error is same as default option (base32).

Also, whatever files are getting uploaded successfully, files are base32 encoded and not b64 on the remote, even though I specified it in the config.

Am I using b64 flag correctly?

Who remembers what rclone was doing many years ago and what bugs it had. You are using VERY old rclone version.

Upgrade to the latest version (v1.65.2 as for now) and try again. Nobody in interested in troubleshooting some ancient version.

1 Like

oh, sorry, I thought I was using latest one :)))
will try to update first

Uninstall your version (you can complain to your distro why they do not maintain it):

sudo apt remove rclone

and install the latest one directly from rclone site:

sudo -v ; curl https://rclone.org/install.sh | sudo bash

1 Like

Have no issues now!
Thank you!

One more question, I already have b32 synced, is it possible to rename them b64 or it's better to delete and sync from the start?

It is possible:

What you do is set up a new crypt remote by copying the old one in the config file, renaming it and adding filename_encoding = base64. Choosing a different destination directory is a good idea here too so the old and the new don't overlap.

You can then do a server side move something like

rclone move --server-side-across-configs -vv old: new:

If too complex just start from scratch.

1 Like

I think you can even go with base32768 - give me a moment to double check.

EDIT: nope - better to use base64:slight_smile:

1 Like

is there any benefit of using b32768 over b64?

For some remotes like onedrive or dropbox it gives you much longer max lengths names. But for S3 remote base64 is the best choice.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.